aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-08-25 00:43:59 +0800
committeritetcu <itetcu@FreeBSD.org>2007-08-25 00:43:59 +0800
commitb42b97d42552dc865334a9d0010c84de6f6b8fa5 (patch)
tree056b38b2f6909a840c16c6b4d9d897da1194c0af /databases
parent62829c83bd16735048e80d2dfea10231b5ee240c (diff)
downloadfreebsd-ports-gnome-b42b97d42552dc865334a9d0010c84de6f6b8fa5.tar.gz
freebsd-ports-gnome-b42b97d42552dc865334a9d0010c84de6f6b8fa5.tar.zst
freebsd-ports-gnome-b42b97d42552dc865334a9d0010c84de6f6b8fa5.zip
- update to 3.1
- WANT_PHP_WEB since it's web-based - default php to 5 and mark ignore with 3 - use WWWDIR - use SUB_FILES for pkg-message PR: ports/115584 Submitted by: Petr Macek (maintainer)
Diffstat (limited to 'databases')
-rw-r--r--databases/mywwwatcher/Makefile20
-rw-r--r--databases/mywwwatcher/distinfo6
-rw-r--r--databases/mywwwatcher/pkg-message5
-rw-r--r--databases/mywwwatcher/pkg-plist88
4 files changed, 57 insertions, 62 deletions
diff --git a/databases/mywwwatcher/Makefile b/databases/mywwwatcher/Makefile
index 1c245ac22e7f..27f83145973d 100644
--- a/databases/mywwwatcher/Makefile
+++ b/databases/mywwwatcher/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mywwwatcher
-PORTVERSION= 3.0
+PORTVERSION= 3.1
CATEGORIES= databases www
MASTER_SITES= http://www.the.cz/mywwwatcher/files/
DISTNAME= mywwwatcher-${PORTVERSION}
@@ -16,21 +16,21 @@ COMMENT= Simply web-based mysql client + tools (dump, import, scheme, ...)
WRKSRC= ${WRKDIR}/mywwwatcher
-DEFAULT_PHP_VER= 4
+WANT_PHP_WEB= yes
+DEFAULT_PHP_VER= 5
USE_PHP= pcre session mysql
+IGNORE_WITH_PHP= 3
NO_BUILD= yes
-PKGMESSAGE= ${PKGDIR}/pkg-message
-PLIST_SUB+= INSTALLDIR=${INSTALLDIR}
-
-INSTALLDIR= www/${PORTNAME}
+SUB_FILES= pkg-message
do-install:
- @${MKDIR} ${PREFIX}/${INSTALLDIR}
- @${CP} -Rp ${WRKSRC}/* ${PREFIX}/${INSTALLDIR}
- @${CHMOD} 775 ${PREFIX}/${INSTALLDIR}/ini
- @${CHMOD} 775 ${PREFIX}/${INSTALLDIR}/query_archive
+ @${MKDIR} ${WWWDIR}
+ @${CP} -Rp ${WRKSRC}/* ${WWWDIR}
+ @${CHMOD} 775 ${WWWDIR}/ini
+ @${CHMOD} 775 ${WWWDIR}/query_archive
+ @${CHOWN} www ${WWWDIR}
@${ECHO_CMD} ""
post-install:
diff --git a/databases/mywwwatcher/distinfo b/databases/mywwwatcher/distinfo
index c917dee8d30e..4bdee6c07506 100644
--- a/databases/mywwwatcher/distinfo
+++ b/databases/mywwwatcher/distinfo
@@ -1,3 +1,3 @@
-MD5 (mywwwatcher-3.0.tar.gz) = fb7279d1bf678234df144701f10cda09
-SHA256 (mywwwatcher-3.0.tar.gz) = c92d99b6188f342f88b70cdc0bbc58fea1460f48b1977fa50dbf53fe54c6f188
-SIZE (mywwwatcher-3.0.tar.gz) = 51238
+MD5 (mywwwatcher-3.1.tar.gz) = 93b2fb9e9183a1b2b91aadd7aa1834bd
+SHA256 (mywwwatcher-3.1.tar.gz) = 3736fbe383c5d8a64d28599d3c31cc6935115965e34e14437b5871beeb583bb3
+SIZE (mywwwatcher-3.1.tar.gz) = 52729
diff --git a/databases/mywwwatcher/pkg-message b/databases/mywwwatcher/pkg-message
deleted file mode 100644
index 90c680f097fd..000000000000
--- a/databases/mywwwatcher/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-***************************************************************
-
-for czech language rename files with extension .cz
-
-***************************************************************
diff --git a/databases/mywwwatcher/pkg-plist b/databases/mywwwatcher/pkg-plist
index eba6c911c5f8..cbf37eff9747 100644
--- a/databases/mywwwatcher/pkg-plist
+++ b/databases/mywwwatcher/pkg-plist
@@ -1,44 +1,44 @@
-%%INSTALLDIR%%/README
-%%INSTALLDIR%%/README.cz
-%%INSTALLDIR%%/copying
-%%INSTALLDIR%%/export.php
-%%INSTALLDIR%%/function.php
-%%INSTALLDIR%%/graphics/cursor_down.gif
-%%INSTALLDIR%%/graphics/cursor_up.gif
-%%INSTALLDIR%%/graphics/intro.gif
-%%INSTALLDIR%%/graphics/intro.gif.cz
-%%INSTALLDIR%%/graphics/outro.gif
-%%INSTALLDIR%%/import.php
-%%INSTALLDIR%%/include/compress.inc.php
-%%INSTALLDIR%%/include/foot.inc.php
-%%INSTALLDIR%%/include/frameset.inc.php
-%%INSTALLDIR%%/include/headers.inc.php
-%%INSTALLDIR%%/include/indexes.inc.php
-%%INSTALLDIR%%/include/sqltips.inc.php
-%%INSTALLDIR%%/include/sqltips.inc.php.cz
-%%INSTALLDIR%%/include/words.inc.php
-%%INSTALLDIR%%/index.php
-%%INSTALLDIR%%/indexes.php
-%%INSTALLDIR%%/ini/default.ini
-%%INSTALLDIR%%/ini/default.ini.cz
-%%INSTALLDIR%%/insert.php
-%%INSTALLDIR%%/lang/cz.lng
-%%INSTALLDIR%%/lang/en.lng
-%%INSTALLDIR%%/logout.php
-%%INSTALLDIR%%/menu.php
-%%INSTALLDIR%%/output.php
-%%INSTALLDIR%%/queries.php
-%%INSTALLDIR%%/query_archive.php
-%%INSTALLDIR%%/query_archive/root.txt
-%%INSTALLDIR%%/scheme.php
-%%INSTALLDIR%%/scripts.js
-%%INSTALLDIR%%/settings.php
-%%INSTALLDIR%%/stat.php
-%%INSTALLDIR%%/styly.css
-%%INSTALLDIR%%/top.php
-@dirrm %%INSTALLDIR%%/query_archive
-@dirrm %%INSTALLDIR%%/lang
-@dirrm %%INSTALLDIR%%/ini
-@dirrm %%INSTALLDIR%%/graphics
-@dirrm %%INSTALLDIR%%/include
-@dirrm %%INSTALLDIR%%
+%%WWWDIR%%/README
+%%WWWDIR%%/README.cz
+%%WWWDIR%%/charset.php
+%%WWWDIR%%/copying
+%%WWWDIR%%/export.php
+%%WWWDIR%%/function.php
+%%WWWDIR%%/graphics/cursor_down.gif
+%%WWWDIR%%/graphics/cursor_up.gif
+%%WWWDIR%%/graphics/intro.gif
+%%WWWDIR%%/graphics/intro.gif.cz
+%%WWWDIR%%/graphics/outro.gif
+%%WWWDIR%%/import.php
+%%WWWDIR%%/include/compress.inc.php
+%%WWWDIR%%/include/foot.inc.php
+%%WWWDIR%%/include/frameset.inc.php
+%%WWWDIR%%/include/headers.inc.php
+%%WWWDIR%%/include/indexes.inc.php
+%%WWWDIR%%/include/sqltips.inc.php
+%%WWWDIR%%/include/sqltips.inc.php.cz
+%%WWWDIR%%/include/words.inc.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/indexes.php
+%%WWWDIR%%/ini/default.ini
+%%WWWDIR%%/ini/default.ini.cz
+%%WWWDIR%%/insert.php
+%%WWWDIR%%/lang/cz.lng
+%%WWWDIR%%/lang/en.lng
+%%WWWDIR%%/logout.php
+%%WWWDIR%%/menu.php
+%%WWWDIR%%/output.php
+%%WWWDIR%%/queries.php
+%%WWWDIR%%/query_archive.php
+%%WWWDIR%%/scheme.php
+%%WWWDIR%%/scripts.js
+%%WWWDIR%%/settings.php
+%%WWWDIR%%/stat.php
+%%WWWDIR%%/style.css
+%%WWWDIR%%/top.php
+@dirrm %%WWWDIR%%/query_archive
+@dirrm %%WWWDIR%%/lang
+@dirrm %%WWWDIR%%/ini
+@dirrm %%WWWDIR%%/graphics
+@dirrm %%WWWDIR%%/include
+@dirrm %%WWWDIR%%