aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2006-01-07 08:28:20 +0800
committerade <ade@FreeBSD.org>2006-01-07 08:28:20 +0800
commitc63710b49bd55ed3c8b748af2eb408015fb41db3 (patch)
treea1b2870445a2990fbee1535ea75e909e79b48a97 /databases
parentc1f206043b26222926184670b87834b35948c03f (diff)
downloadfreebsd-ports-gnome-c63710b49bd55ed3c8b748af2eb408015fb41db3.tar.gz
freebsd-ports-gnome-c63710b49bd55ed3c8b748af2eb408015fb41db3.tar.zst
freebsd-ports-gnome-c63710b49bd55ed3c8b748af2eb408015fb41db3.zip
IP4R is a contributed PostgreSQL module that embraces and extends the
existing 'inet' and 'cidr' built-in types, providing extra functionality and simplicity to IPv4 address lookup within large-scale environments.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ip4r/Makefile38
-rw-r--r--databases/ip4r/distinfo3
-rw-r--r--databases/ip4r/pkg-descr5
-rw-r--r--databases/ip4r/pkg-plist6
5 files changed, 53 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 87ac5d1484b8..edeccde890ec 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -68,6 +68,7 @@
SUBDIR += grass-i18n
SUBDIR += gtksql
SUBDIR += hk_classes
+ SUBDIR += ip4r
SUBDIR += ipa_sdb
SUBDIR += isql-viewer
SUBDIR += jasperreports
diff --git a/databases/ip4r/Makefile b/databases/ip4r/Makefile
new file mode 100644
index 000000000000..7e426bd36ed4
--- /dev/null
+++ b/databases/ip4r/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ip4r
+# Date created: 15th December 2005
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ip4r
+PORTVERSION= 1.0
+CATEGORIES= databases net
+MASTER_SITES= http://pgfoundry.org/frs/download.php/537/
+
+MAINTAINER= ade@FreeBSD.org
+COMMENT= IPv4 and IPv4 range index type for PostgreSQL
+
+USE_PGSQL= YES
+USE_GMAKE= YES
+WANT_PGSQL_VER?= 81
+
+# 74 is not strictly true, but requires extracting the appropriate
+# postgresql-contrib tarball, and associated heavy lifting.
+# In order to keep this port simple, we assume >= 8.0
+BROKEN_WITH_PGSQL= 73 74
+
+MAKE_ARGS= USE_PGXS=1
+
+# In order to make this port PREFIX-safe, we override the install target
+# and install the three files manually
+do-install:
+ @${INSTALL} -m ${BINMODE} ${WRKSRC}/ip4r.so ${PREFIX}/lib/postgresql
+ @${MKDIR} ${PREFIX}/share/postgresql/contrib
+ @${INSTALL_DATA} ${WRKSRC}/ip4r.sql \
+ ${PREFIX}/share/postgresql/contrib
+ @${MKDIR} ${PREFIX}/share/doc/postgresql/contrib
+ @${INSTALL_DATA} ${WRKSRC}/README.ip4r \
+ ${PREFIX}/share/doc/postgresql/contrib
+
+.include <bsd.port.mk>
diff --git a/databases/ip4r/distinfo b/databases/ip4r/distinfo
new file mode 100644
index 000000000000..08edf1fc10b1
--- /dev/null
+++ b/databases/ip4r/distinfo
@@ -0,0 +1,3 @@
+MD5 (ip4r-1.0.tar.gz) = 884cfc931027043d00218e931b1fd7f2
+SHA256 (ip4r-1.0.tar.gz) = 00cf7c4595e4cd06ee783b8081586e60ad969be1b075b66b690c649584f7d2d3
+SIZE (ip4r-1.0.tar.gz) = 17206
diff --git a/databases/ip4r/pkg-descr b/databases/ip4r/pkg-descr
new file mode 100644
index 000000000000..703ff6f37edf
--- /dev/null
+++ b/databases/ip4r/pkg-descr
@@ -0,0 +1,5 @@
+IP4R is a contributed PostgreSQL module that embraces and extends the
+existing 'inet' and 'cidr' built-in types, providing extra functionality
+and simplicity to IPv4 address lookup within large-scale environments.
+
+WWW: http://pgfoundry.org/projects/ip4r/
diff --git a/databases/ip4r/pkg-plist b/databases/ip4r/pkg-plist
new file mode 100644
index 000000000000..8623167a89d6
--- /dev/null
+++ b/databases/ip4r/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+lib/postgresql/ip4r.so
+share/doc/postgresql/contrib/README.ip4r
+share/postgresql/contrib/ip4r.sql
+@unexec rmdir %D/share/doc/postgresql/contrib 2>/dev/null || true
+@unexec rmdir %D/share/postgresql/contrib 2>/dev/null || true