aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-22 12:13:24 +0800
committermarcus <marcus@FreeBSD.org>2003-04-22 12:13:24 +0800
commite19daf26a391b9070456a133fb8dbaf46ca059c8 (patch)
tree976e04d4756a1e6976552450e77e2790020a5957 /databases
parent5412157d938a365ebae3e49c4ac090a7ba95295d (diff)
downloadfreebsd-ports-gnome-e19daf26a391b9070456a133fb8dbaf46ca059c8.tar.gz
freebsd-ports-gnome-e19daf26a391b9070456a133fb8dbaf46ca059c8.tar.zst
freebsd-ports-gnome-e19daf26a391b9070456a133fb8dbaf46ca059c8.zip
Convert to new GNOME infrastructure.
Diffstat (limited to 'databases')
-rw-r--r--databases/libgda2/Makefile5
-rw-r--r--databases/libgda3/Makefile5
-rw-r--r--databases/mergeant/Makefile6
3 files changed, 3 insertions, 13 deletions
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 5fccc79bb33d..ca53911e8933 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -18,8 +18,6 @@ COMMENT= Provides uniform access to different kinds of data sources
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
- glib-2.0.200:${PORTSDIR}/devel/glib20 \
- xslt.1:${PORTSDIR}/textproc/libxslt \
popt.0:${PORTSDIR}/devel/popt
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
@@ -27,12 +25,11 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+USE_GNOME= gnomeprefix gnomehack gnomehier glib20 libxslt
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -lgdbm"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gda-config-tool.1
MAN5= gda-config.5
diff --git a/databases/libgda3/Makefile b/databases/libgda3/Makefile
index 5fccc79bb33d..ca53911e8933 100644
--- a/databases/libgda3/Makefile
+++ b/databases/libgda3/Makefile
@@ -18,8 +18,6 @@ COMMENT= Provides uniform access to different kinds of data sources
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
- glib-2.0.200:${PORTSDIR}/devel/glib20 \
- xslt.1:${PORTSDIR}/textproc/libxslt \
popt.0:${PORTSDIR}/devel/popt
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
@@ -27,12 +25,11 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+USE_GNOME= gnomeprefix gnomehack gnomehier glib20 libxslt
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -lgdbm"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gda-config-tool.1
MAN5= gda-config.5
diff --git a/databases/mergeant/Makefile b/databases/mergeant/Makefile
index f0eee69981be..d38a98a59b3b 100644
--- a/databases/mergeant/Makefile
+++ b/databases/mergeant/Makefile
@@ -15,19 +15,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Provide uniform access to data sources for the GNOME 2.0 environment
-LIB_DEPENDS= gnomedb-2.2:${PORTSDIR}/databases/libgnomedb \
- gnomeprintui-2-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack libgnomedb libgnomeprintui
USE_PERL5= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \