aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-24 18:43:14 +0800
committerpgj <pgj@FreeBSD.org>2012-06-24 18:43:14 +0800
commitf7fe37c1165651000a7aa36ba48b36ae672f7e26 (patch)
treebd0eff083e798d6fb2157554a3d44958174e935b /databases
parentfaf558a2016093282bcd5c88d21971ce29c6f687 (diff)
downloadfreebsd-ports-gnome-f7fe37c1165651000a7aa36ba48b36ae672f7e26.tar.gz
freebsd-ports-gnome-f7fe37c1165651000a7aa36ba48b36ae672f7e26.tar.zst
freebsd-ports-gnome-f7fe37c1165651000a7aa36ba48b36ae672f7e26.zip
This package includes a thin sqlite3 wrapper based on the direct-sqlite
package, as well as the entire C library, so there are no system dependencies. WWW: http://www.yesodweb.com/book/persistent Obtained from: FreeBSD Haskell
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/hs-persistent-sqlite/Makefile21
-rw-r--r--databases/hs-persistent-sqlite/distinfo2
-rw-r--r--databases/hs-persistent-sqlite/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 865002bfdf49..d699284d160b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -106,6 +106,7 @@
SUBDIR += hk_classes
SUBDIR += hs-mysql
SUBDIR += hs-persistent
+ SUBDIR += hs-persistent-sqlite
SUBDIR += hs-persistent-template
SUBDIR += hsqldb
SUBDIR += hypertable
diff --git a/databases/hs-persistent-sqlite/Makefile b/databases/hs-persistent-sqlite/Makefile
new file mode 100644
index 000000000000..66b582ea1f7c
--- /dev/null
+++ b/databases/hs-persistent-sqlite/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-persistent-sqlite
+# Date created: June 10, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= persistent-sqlite
+PORTVERSION= 0.9.0.2
+CATEGORIES= databases haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Backend for the persistent library using sqlite3
+
+LICENSE= MIT
+
+USE_CABAL= aeson>=0.5 conduit>=0.4 monad-control>=0.2 persistent>=0.9 \
+ text>=0.7 transformers>=0.2.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/databases/hs-persistent-sqlite/distinfo b/databases/hs-persistent-sqlite/distinfo
new file mode 100644
index 000000000000..076d0c946a02
--- /dev/null
+++ b/databases/hs-persistent-sqlite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/persistent-sqlite-0.9.0.2.tar.gz) = eb8fa320475f28b48d1f3f9e4bb84744aac7d4fb6cfaa8455577e13147f895a7
+SIZE (cabal/persistent-sqlite-0.9.0.2.tar.gz) = 1108691
diff --git a/databases/hs-persistent-sqlite/pkg-descr b/databases/hs-persistent-sqlite/pkg-descr
new file mode 100644
index 000000000000..05b30f8ce623
--- /dev/null
+++ b/databases/hs-persistent-sqlite/pkg-descr
@@ -0,0 +1,5 @@
+This package includes a thin sqlite3 wrapper based on the direct-sqlite
+package, as well as the entire C library, so there are no system
+dependencies.
+
+WWW: http://www.yesodweb.com/book/persistent