aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-23 10:01:46 +0800
committerwen <wen@FreeBSD.org>2010-12-23 10:01:46 +0800
commit010df0d068a22ec2ec36b416de4a34c34c5ebdfb (patch)
treea9470135206f93e6ff02c273c1aeb987a4739dc0 /databases
parent03a4c6d254ab2cc40544a1c3ac3a761f311c7844 (diff)
downloadfreebsd-ports-gnome-010df0d068a22ec2ec36b416de4a34c34c5ebdfb.tar.gz
freebsd-ports-gnome-010df0d068a22ec2ec36b416de4a34c34c5ebdfb.tar.zst
freebsd-ports-gnome-010df0d068a22ec2ec36b416de4a34c34c5ebdfb.zip
Dancer::Plugin::Database provides an easy way to obtain a connected DBI database
handle by simply calling the database keyword within your Dancer application. Returns a Dancer::Plugin::Database::Handle object, which is a subclass of DBI's DBI::db connection handle object, so it does everything you'd expect to do with DBI, but also adds a few convenience methods. See the documentation for Dancer::Plugin::Database::Handle for full details of those. WWW: http://search.cpan.org/dist/Dancer-Plugin-Database
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Dancer-Plugin-Database/Makefile26
-rw-r--r--databases/p5-Dancer-Plugin-Database/distinfo2
-rw-r--r--databases/p5-Dancer-Plugin-Database/pkg-descr9
-rw-r--r--databases/p5-Dancer-Plugin-Database/pkg-plist9
5 files changed, 47 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b376274aec34..e62f152bc6a4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -395,6 +395,7 @@
SUBDIR += p5-DBZ_File
SUBDIR += p5-DMOZ-ParseRDF
SUBDIR += p5-DWH_File
+ SUBDIR += p5-Dancer-Plugin-Database
SUBDIR += p5-Data-Page
SUBDIR += p5-Data-Pageset
SUBDIR += p5-Exception-Class-DBI
diff --git a/databases/p5-Dancer-Plugin-Database/Makefile b/databases/p5-Dancer-Plugin-Database/Makefile
new file mode 100644
index 000000000000..cd843e563cab
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Database/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Dancer-Plugin-Database
+# Date created: Dec 23, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Plugin-Database
+PORTVERSION= 0.91
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Easy database connections for Dancer applications
+
+BUILD_DEPENDS= p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
+ p5-Dancer>=1.175:${PORTSDIR}/www/p5-Dancer
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Dancer::Plugin::Database.3 \
+ Dancer::Plugin::Database::Handle.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Dancer-Plugin-Database/distinfo b/databases/p5-Dancer-Plugin-Database/distinfo
new file mode 100644
index 000000000000..d0c30e6514a4
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Database/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-Database-0.91.tar.gz) = feda9e99b7fcf5f738e0633b5b71b09cf871c76fd874b51a09fc849c63e3af53
+SIZE (Dancer-Plugin-Database-0.91.tar.gz) = 12300
diff --git a/databases/p5-Dancer-Plugin-Database/pkg-descr b/databases/p5-Dancer-Plugin-Database/pkg-descr
new file mode 100644
index 000000000000..944050cafd4a
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Database/pkg-descr
@@ -0,0 +1,9 @@
+Dancer::Plugin::Database provides an easy way to obtain a connected DBI database
+handle by simply calling the database keyword within your Dancer application.
+
+Returns a Dancer::Plugin::Database::Handle object, which is a subclass of DBI's
+DBI::db connection handle object, so it does everything you'd expect to do with
+DBI, but also adds a few convenience methods. See the documentation for
+Dancer::Plugin::Database::Handle for full details of those.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-Database
diff --git a/databases/p5-Dancer-Plugin-Database/pkg-plist b/databases/p5-Dancer-Plugin-Database/pkg-plist
new file mode 100644
index 000000000000..a1414d3394cf
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Database/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Dancer/Plugin/Database/Handle.pm
+%%SITE_PERL%%/Dancer/Plugin/Database.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Database/.packlist
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin/Database
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/Dancer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Database
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer