aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-10-28 02:05:42 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-10-28 02:05:42 +0800
commit0197b38c90048a2d254e443d08a4e5d8fcc1c2dc (patch)
treec81046bb581124f4919d051f241a81ef7100c5ce /databases
parent53f165adbebd3855e64bfa9f01fe8d19c13b03b3 (diff)
downloadfreebsd-ports-gnome-0197b38c90048a2d254e443d08a4e5d8fcc1c2dc.tar.gz
freebsd-ports-gnome-0197b38c90048a2d254e443d08a4e5d8fcc1c2dc.tar.zst
freebsd-ports-gnome-0197b38c90048a2d254e443d08a4e5d8fcc1c2dc.zip
- Update to 1.2.7
- While I'm here: - Convert to new LIB_DEPENDS format - Respect CC - Use USES=gmake - Support STAGEDIR Changes: http://www.lemke-it.com/litexec?request=pubclogcegodbd PR: ports/183359 Submitted by: Kurt Jaeger <fbsd-ports@opsec.eu> (maintainer)
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBD-cego/Makefile13
-rw-r--r--databases/p5-DBD-cego/distinfo4
-rw-r--r--databases/p5-DBD-cego/files/patch-makefile-pl5
-rw-r--r--databases/p5-DBD-cego/pkg-plist1
4 files changed, 10 insertions, 13 deletions
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index fa6120d8702d..f3429cde31e3 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= DBD-cego
-PORTVERSION= 1.2.6
+PORTVERSION= 1.2.7
CATEGORIES= databases perl5
MASTER_SITES= http://www.lemke-it.com/
PKGNAMEPREFIX= p5-
@@ -14,20 +14,17 @@ LICENSE= GPLv3
BUILD_DEPENDS= p5-DBI>=1.628:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= p5-DBI>=1.628:${PORTSDIR}/databases/p5-DBI
-LIB_DEPENDS= cego.1:${PORTSDIR}/databases/cego
+LIB_DEPENDS= libcego.so:${PORTSDIR}/databases/cego
.if defined(.PARSEDIR)
-USE_GMAKE= yes
+USES= gmake
.endif
-USES= perl5
+USES+= perl5
USE_PERL5= configure
CC:= ${CXX}
-MAN3= DBD::Cego.3
-
-NO_STAGE= yes
post-configure:
- @${REINPLACE_CMD} -e 's|fno-strict-aliasing|fno-strict-aliasing -fpermissive|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|fno-strict-aliasing|& -fpermissive|g' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-cego/distinfo b/databases/p5-DBD-cego/distinfo
index a7ea05676cf9..ed24b6b3f4c6 100644
--- a/databases/p5-DBD-cego/distinfo
+++ b/databases/p5-DBD-cego/distinfo
@@ -1,2 +1,2 @@
-SHA256 (DBD-cego-1.2.6.tar.gz) = d944addd62cb3c6bdc853269a7f645f99a7fa255113c7279c81e06313d4b98e9
-SIZE (DBD-cego-1.2.6.tar.gz) = 28192
+SHA256 (DBD-cego-1.2.7.tar.gz) = cf7febaaedbb545f2fe0308dd09e3613653bd302b7837c7213c3267946004f59
+SIZE (DBD-cego-1.2.7.tar.gz) = 28293
diff --git a/databases/p5-DBD-cego/files/patch-makefile-pl b/databases/p5-DBD-cego/files/patch-makefile-pl
index 38520dc61cdf..d3eee863eb20 100644
--- a/databases/p5-DBD-cego/files/patch-makefile-pl
+++ b/databases/p5-DBD-cego/files/patch-makefile-pl
@@ -1,6 +1,6 @@
--- Makefile.PL-orig 2013-07-09 09:44:14.000000000 +0200
+++ Makefile.PL 2013-07-09 09:48:24.000000000 +0200
-@@ -28,33 +28,23 @@
+@@ -28,33 +28,22 @@
Getopt::Long::GetOptions(
$opt,
"help",
@@ -34,9 +34,8 @@
- 'OPTIMIZE' => '-O6 -DNDEBUG=1',
+ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include',
+ 'MYEXTLIB' => '-lcego -llfcxml -llfcbase',
-+ 'CC' => 'g++',
+ 'CCFLAGS' => '-O2 -pipe -fno-strict-aliasing -fpermissive',
-+ 'LD' => 'g++ -L/usr/local/lib',
++ 'LD' => '$(CC) -L/usr/local/lib',
+ 'XSPROTOARG' => '-noprototypes',
+ 'OPTIMIZE' => '-O3 -DNDEBUG=1',
'XSOPT' => '-C++',
diff --git a/databases/p5-DBD-cego/pkg-plist b/databases/p5-DBD-cego/pkg-plist
index ba2efa4b73e1..2af24f7b695a 100644
--- a/databases/p5-DBD-cego/pkg-plist
+++ b/databases/p5-DBD-cego/pkg-plist
@@ -2,6 +2,7 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego/Cego.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego/Cego.so
+%%PERL5_MAN3%%/DBD::Cego.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Cego
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/DBD