aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-07-01 14:22:55 +0800
committerwen <wen@FreeBSD.org>2011-07-01 14:22:55 +0800
commit38c45ef9006db9c9218d6203cae029108b08c3d6 (patch)
tree3309f2ba0b164bd87d1e151b5c48ef1872860739 /databases
parentf169d5819da1f760df39fc211339f7675e96b7a7 (diff)
downloadfreebsd-ports-gnome-38c45ef9006db9c9218d6203cae029108b08c3d6.tar.gz
freebsd-ports-gnome-38c45ef9006db9c9218d6203cae029108b08c3d6.tar.zst
freebsd-ports-gnome-38c45ef9006db9c9218d6203cae029108b08c3d6.zip
- Enable GUI for shp2pgsql loader
PR: ports/157605 Submitted by: Rainer Hurling <rhurlin@gwdg.de> Approved by: maintainer(timeout, >20 days)
Diffstat (limited to 'databases')
-rw-r--r--databases/postgis/Makefile17
-rw-r--r--databases/postgis/pkg-plist1
2 files changed, 16 insertions, 2 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 9579c8c8d68b..e40e6a838f29 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -7,9 +7,10 @@
PORTNAME= postgis
PORTVERSION= 1.5.2
+PORTREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= http://postgis.refractions.net/download/ \
- http://www.postgis.org/download/
+ http://www.postgis.org/download/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Adds support for geographic objects to PostgreSQL databases
@@ -25,15 +26,27 @@ USE_ICONV= yes
USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
+OPTIONS= LOADERGUI "Enable shp2pgsql-gui" Off
+
+.include <bsd.port.options.mk>
+
INSTALL_TARGET= install
GNU_CONFIGURE= yes
+.if defined(WITH_LOADERGUI)
+USE_GNOME= libxml2 gtk20
+CONFIGURE_ARGS= --with-projdir=${LOCALBASE} --with-gui
+PLIST_SUB+= LOADERGUI=""
+.else
USE_GNOME= libxml2
+CONFIGURE_ARGS= --with-projdir=${LOCALBASE}
+PLIST_SUB+= LOADERGUI="@comment "
+.endif
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= DATADIR=${DATADIR} DOCSDIR=${DOCSDIR}
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS= --with-projdir=${LOCALBASE}
.include <bsd.port.pre.mk>
diff --git a/databases/postgis/pkg-plist b/databases/postgis/pkg-plist
index fb17a2cafde4..72c6cbf38c46 100644
--- a/databases/postgis/pkg-plist
+++ b/databases/postgis/pkg-plist
@@ -1,5 +1,6 @@
bin/pgsql2shp
bin/shp2pgsql
+%%LOADERGUI%%bin/shp2pgsql-gui
lib/postgresql/liblwgeom.so
lib/postgresql/liblwgeom.so.1
lib/postgresql/postgis-1.5.so