aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-16 01:55:27 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-16 01:55:27 +0800
commit3f0c21c7611bfc976f2ff132a37772c41cdbcea4 (patch)
treeb82661543a7408d02d911eeebc128db1617ccf93 /databases
parente88213e43993bdf8613782da29b34a04ddb6ca2a (diff)
downloadfreebsd-ports-gnome-3f0c21c7611bfc976f2ff132a37772c41cdbcea4.tar.gz
freebsd-ports-gnome-3f0c21c7611bfc976f2ff132a37772c41cdbcea4.tar.zst
freebsd-ports-gnome-3f0c21c7611bfc976f2ff132a37772c41cdbcea4.zip
- Fix build with thrift-0.9.1
- Add LICENSE - Support STAGEDIR - Use single space after WWW: PR: ports/183982 Submitted by: Gasol Wu <gasol.wu@gmail.com> (maintainer)
Diffstat (limited to 'databases')
-rw-r--r--databases/php5-pdo_cassandra/Makefile34
-rw-r--r--databases/php5-pdo_cassandra/files/patch-config.m422
-rw-r--r--databases/php5-pdo_cassandra/pkg-descr2
3 files changed, 46 insertions, 12 deletions
diff --git a/databases/php5-pdo_cassandra/Makefile b/databases/php5-pdo_cassandra/Makefile
index 9d7c0335be13..198e8c68e7c7 100644
--- a/databases/php5-pdo_cassandra/Makefile
+++ b/databases/php5-pdo_cassandra/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pdo_cassandra
PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= https://github.com/${GITHUB_USER}/php-${PORTNAME}/tarball/${GITREVISION}/
PKGNAMEPREFIX= php5-
@@ -12,8 +12,9 @@ DISTNAME= ${GITHUB_USER}-php-${PORTNAME}-${GITTAG}-14-g${GITREVISION}
MAINTAINER= gasol.wu@gmail.com
COMMENT= PDO driver for Apache Cassandra
-LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
- thrift:${PORTSDIR}/devel/thrift
+LICENSE= AL2
+
+LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs
GITREVISION= 7debd5b
GITTAG= 0.8-support
@@ -27,14 +28,25 @@ USE_PHP= pdo
USE_PHPEXT= yes
DEFAULT_PHP_VER=5
IGNORE_WITH_PHP=52
-THRIFT_CMD= ${LOCALBASE}/bin/thrift
-NO_STAGE= yes
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/thrift/bsd.thrift.mk"
+
+THRIFT_MAJOR_VER= ${THRIFT_PORTVERSION:R:R}
+THRIFT_MINOR_VER= ${THRIFT_PORTVERSION:R:E}
+THRIFT_PATCH_VER= ${THRIFT_PORTVERSION:E}
+
+.if ${THRIFT_MAJOR_VER} >= 0 || ${THRIFT_MINOR_VER} >= 9 || ${THRIFT_PATCH_VER} >= 1
+LIB_DEPENDS+= libthrift.so:${PORTSDIR}/devel/thrift-cpp
+BUILD_DEPENDS+= ${LOCALBASE}/bin/thrift:${PORTSDIR}/devel/thrift
+.else
+LIB_DEPENDS+= libthrift.so:${PORTSDIR}/devel/thrift
+.endif
+
post-configure:
- thrift_version=`${THRIFT_CMD} -version | ${AWK} '{print $$3}'`; \
- if [ "$$thrift_version" = "0.8.0" ]; then \
- ${REINPLACE_CMD} 's/\([^:]\)apache::thrift/\1 ::apache::thrift/g' ${WRKSRC}/gen-cpp/Cassandra.h; \
- ${REINPLACE_CMD} 's/\([^:]\)apache::thrift/\1 ::apache::thrift/g' ${WRKSRC}/gen-cpp/Cassandra.cpp; \
- fi
+.if ${THRIFT_PORTVERSION} == "0.8.0"
+ ${REINPLACE_CMD} 's/\([^:]\)apache::thrift/\1 ::apache::thrift/g' ${WRKSRC}/gen-cpp/Cassandra.h
+ ${REINPLACE_CMD} 's/\([^:]\)apache::thrift/\1 ::apache::thrift/g' ${WRKSRC}/gen-cpp/Cassandra.cpp
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/php5-pdo_cassandra/files/patch-config.m4 b/databases/php5-pdo_cassandra/files/patch-config.m4
new file mode 100644
index 000000000000..0e2fb8f3ef4a
--- /dev/null
+++ b/databases/php5-pdo_cassandra/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- ./config.m4.orig 2011-12-30 17:41:22.000000000 +0800
++++ ./config.m4 2013-11-14 21:46:12.000000000 +0800
+@@ -38,8 +38,18 @@
+ PHP_THRIFT_VERSION=`${PKG_CONFIG} thrift --modversion`
+
+ AC_MSG_RESULT([found version ${PHP_THRIFT_VERSION}])
++ ac_IFS=$IFS
++ IFS="."
++ set $PHP_THRIFT_VERSION
++ IFS=$ac_IFS
++ dnl workaround for changes of THRIFT-1968
++ THRIFT_VERSION=`expr [$]1 \* 10000 + [$]2 \* 100 + [$]3`
++ if test "$THRIFT_VERSION" -ge "901"; then
++ PHP_THRIFT_INCS="-I`${PKG_CONFIG} thrift --variable=includedir`/thrift"
++ else
++ PHP_THRIFT_INCS=`${PKG_CONFIG} thrift --cflags`
++ fi
+ PHP_THRIFT_LIBS=`${PKG_CONFIG} thrift --libs`
+- PHP_THRIFT_INCS=`${PKG_CONFIG} thrift --cflags`
+
+ PHP_EVAL_LIBLINE(${PHP_THRIFT_LIBS}, PDO_CASSANDRA_SHARED_LIBADD)
+ PHP_EVAL_INCLINE(${PHP_THRIFT_INCS})
diff --git a/databases/php5-pdo_cassandra/pkg-descr b/databases/php5-pdo_cassandra/pkg-descr
index f278d4f5d294..3d8747110fd5 100644
--- a/databases/php5-pdo_cassandra/pkg-descr
+++ b/databases/php5-pdo_cassandra/pkg-descr
@@ -7,4 +7,4 @@ BigTable. Like Dynamo, Cassandra is eventually consistent. Like
BigTable, Cassandra provides a ColumnFamily-based data model richer
than typical key/value systems.
-WWW: http://code.google.com/a/apache-extras.org/p/cassandra-pdo/
+WWW: http://code.google.com/a/apache-extras.org/p/cassandra-pdo/