aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-26 18:34:31 +0800
committersat <sat@FreeBSD.org>2006-05-26 18:34:31 +0800
commit64b5f34f5109649c66e7909c5d8b8fd106495899 (patch)
treede351463274d202c8156d21b53930df09bfa6177 /databases
parent49d822c5ab278c75ce7559c49f6c119c0d1dc130 (diff)
downloadfreebsd-ports-gnome-64b5f34f5109649c66e7909c5d8b8fd106495899.tar.gz
freebsd-ports-gnome-64b5f34f5109649c66e7909c5d8b8fd106495899.tar.zst
freebsd-ports-gnome-64b5f34f5109649c66e7909c5d8b8fd106495899.zip
Add port databases/p5-DBIx-SQLite-Simple:
DBIx::SQLite::Simple - easy access to SQLite databases using objects WWW: http://search.cpan.org/dist/DBIx-SQLite-Simple/ Approved by: krion (mentor)
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-SQLite-Simple/Makefile27
-rw-r--r--databases/p5-DBIx-SQLite-Simple/distinfo3
-rw-r--r--databases/p5-DBIx-SQLite-Simple/pkg-descr3
-rw-r--r--databases/p5-DBIx-SQLite-Simple/pkg-plist9
5 files changed, 43 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 33ad7970334b..430545c7eefb 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -230,6 +230,7 @@
SUBDIR += p5-DBIx-SearchBuilder
SUBDIR += p5-DBIx-Sequence
SUBDIR += p5-DBIx-Simple
+ SUBDIR += p5-DBIx-SQLite-Simple
SUBDIR += p5-DBIx-Table
SUBDIR += p5-DBIx-TableHash
SUBDIR += p5-DBIx-Tree
diff --git a/databases/p5-DBIx-SQLite-Simple/Makefile b/databases/p5-DBIx-SQLite-Simple/Makefile
new file mode 100644
index 000000000000..cf4cab31254e
--- /dev/null
+++ b/databases/p5-DBIx-SQLite-Simple/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-DBIx-SQLite-Simple
+# Date created: 26 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-SQLite-Simple
+PORTVERSION= 0.32
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Easy access to SQLite databases using objects
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Gomor.pm:${PORTSDIR}/devel/p5-Class-Gomor \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::SQLite::Simple.3 \
+ DBIx::SQLite::Simple::Table.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-SQLite-Simple/distinfo b/databases/p5-DBIx-SQLite-Simple/distinfo
new file mode 100644
index 000000000000..fd1cbfc6f4e6
--- /dev/null
+++ b/databases/p5-DBIx-SQLite-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-SQLite-Simple-0.32.tar.gz) = 115ccbf9b0b2983c5e785bf6b5e32bac
+SHA256 (DBIx-SQLite-Simple-0.32.tar.gz) = 3063b38ce0cdb7605660d073a48dfce3d368fe32a78e9e40cef96e5e23ec07d0
+SIZE (DBIx-SQLite-Simple-0.32.tar.gz) = 7805
diff --git a/databases/p5-DBIx-SQLite-Simple/pkg-descr b/databases/p5-DBIx-SQLite-Simple/pkg-descr
new file mode 100644
index 000000000000..9e126d178898
--- /dev/null
+++ b/databases/p5-DBIx-SQLite-Simple/pkg-descr
@@ -0,0 +1,3 @@
+DBIx::SQLite::Simple - easy access to SQLite databases using objects
+
+WWW: http://search.cpan.org/dist/DBIx-SQLite-Simple/
diff --git a/databases/p5-DBIx-SQLite-Simple/pkg-plist b/databases/p5-DBIx-SQLite-Simple/pkg-plist
new file mode 100644
index 000000000000..4a4fbfe30cab
--- /dev/null
+++ b/databases/p5-DBIx-SQLite-Simple/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/DBIx/SQLite/Simple.pm
+%%SITE_PERL%%/DBIx/SQLite/Simple/Table.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/SQLite/Simple/.packlist
+@dirrm %%SITE_PERL%%/DBIx/SQLite/Simple
+@dirrmtry %%SITE_PERL%%/DBIx/SQLite
+@dirrmtry %%SITE_PERL%%/DBIx
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/SQLite/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/SQLite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx