aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2013-03-24 12:35:29 +0800
committeracm <acm@FreeBSD.org>2013-03-24 12:35:29 +0800
commit711d6fb873d5995d71624286e46b81486e7ebda9 (patch)
tree7f388ab4e1b011e5d548fdef6f7bb9fe02faa793 /databases
parente6824c0bb9e201028476cf7af82205f1b522bea3 (diff)
downloadfreebsd-ports-gnome-711d6fb873d5995d71624286e46b81486e7ebda9.tar.gz
freebsd-ports-gnome-711d6fb873d5995d71624286e46b81486e7ebda9.tar.zst
freebsd-ports-gnome-711d6fb873d5995d71624286e46b81486e7ebda9.zip
- Update to 2.0.7
- Move files/pkg-install.in to pkg-install - Add new warning message when it is building as root - Remove obsolete patch files - Fix installation of fbintl.conf to ${PREFIX}/etc/firebird [1]. PR: 176191 [1] Submitted by: Jose Jachuf <jjachuf __ __gmail.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/firebird25-server/Makefile14
-rw-r--r--databases/firebird25-server/distinfo4
-rw-r--r--databases/firebird25-server/files/patch-builds-posix_empty.vers11
-rw-r--r--databases/firebird25-server/files/pkg-install.in26
-rw-r--r--databases/firebird25-server/pkg-install46
5 files changed, 66 insertions, 35 deletions
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index 280ee40a8bca..aa83355b4ddf 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= firebird
-PORTVERSION= 2.5.1
-PORTREVISION?= 2
+PORTVERSION= 2.5.2
+PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/.0//}-Release/
PKGNAMESUFFIX?= -server
-DISTNAME= ${PORTNAME:S/f/F/}-${PORTVERSION}.26351-0
+DISTNAME= ${PORTNAME:S/f/F/}-${PORTVERSION}.26539-0
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= --with-system-editline \
--with-fbconf=${CONFDIR} \
--with-fbglock=${LOCALSTATEDIR} \
--with-fbhelp=${LOCALSTATEDIR}/help \
- --with-fbintl=${LIBEXECDIR}/intl \
+ --with-fbintl=${CONFDIR}/intl \
--with-fblog=${LOCALSTATEDIR} \
--with-fbmsg=${DATADIR} \
--with-fbplugins=${LIBEXECDIR}/plugins \
@@ -75,7 +75,7 @@ LIB_DEPENDS+= fbembed.2:${PORTSDIR}/databases/firebird25-client
ALL_TARGET= firebird_embedded
USE_RC_SUBR= firebird
-SUB_FILES= pkg-install pkg-message
+SUB_FILES= pkg-message
UTIL_SBIN= fb_inet_server fb_lock_print fb_smp_server
UTIL_BIN= fbguard fbsplit fbstat fbsvcmgr fbtracemgr gbak gdef gfix gsec \
@@ -129,9 +129,9 @@ post-install:
.ifndef WITHOUT_IPC_CLEANUP
pre-build:
.ifndef PACKAGE_BUILDING
- @if [ `${ID} -u` -eq 0 ]; then \
- ${ECHO_MSG} "==> Please do not build ${PORTNAME} as 'root' because this may cause conflicts with SysV semaphores of running services."; exit 1; fi
+ @${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
.endif
+
${MAKE} -C ${WRKSRC}/extern/btyacc
[ -f ${WRKDIR}/ipcs.pre.build ] || ${IPCS_CMD} -s | ${TAIL} -n +3 | \
${GREP} -F `${ID} -un` | ${CAT} > ${WRKDIR}/ipcs.pre.build
diff --git a/databases/firebird25-server/distinfo b/databases/firebird25-server/distinfo
index d895611eee51..4f51ea61402c 100644
--- a/databases/firebird25-server/distinfo
+++ b/databases/firebird25-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firebird/Firebird-2.5.1.26351-0.tar.bz2) = c4d236e7a9ab3ca00df3faca80f55175d11052637369c877b3e22cd377edb813
-SIZE (firebird/Firebird-2.5.1.26351-0.tar.bz2) = 13665242
+SHA256 (firebird/Firebird-2.5.2.26539-0.tar.bz2) = 6b90e5579f9dc3f527b7cf84ac869682aa9582a61f81c6288926c332a863abc8
+SIZE (firebird/Firebird-2.5.2.26539-0.tar.bz2) = 13708119
diff --git a/databases/firebird25-server/files/patch-builds-posix_empty.vers b/databases/firebird25-server/files/patch-builds-posix_empty.vers
new file mode 100644
index 000000000000..204bd00acf21
--- /dev/null
+++ b/databases/firebird25-server/files/patch-builds-posix_empty.vers
@@ -0,0 +1,11 @@
+--- builds/posix/empty.vers 2013-03-23 02:37:17.000000000 -0500
++++ builds/posix/empty.vers 2013-03-23 02:37:33.000000000 -0500
+@@ -27,6 +27,8 @@
+ {
+ global:
+ main;
++ __progname;
++ environ;
+
+ local:
+ *;
diff --git a/databases/firebird25-server/files/pkg-install.in b/databases/firebird25-server/files/pkg-install.in
deleted file mode 100644
index b80c710d0b25..000000000000
--- a/databases/firebird25-server/files/pkg-install.in
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD: /tmp/pcvs/ports/databases/firebird25-server/files/pkg-install.in,v 1.2 2011-07-10 17:37:11 crees Exp $
-
-PATH=/bin:/usr/bin:/usr/sbin
-
-case $2 in
-POST-INSTALL)
-cd /var/db/firebird
-
-# Lock files
-
-for i in isc_init1 isc_lock1 isc_event1
-do
- FileName=$i.`hostname`
- touch $FileName
- chmod uga=rw $FileName
- chown firebird:firebird $FileName
-done
-
-touch firebird.log
-chown firebird:firebird firebird.log security2.fdb
-
-;;
-
-esac
diff --git a/databases/firebird25-server/pkg-install b/databases/firebird25-server/pkg-install
new file mode 100644
index 000000000000..df5c2c9674fb
--- /dev/null
+++ b/databases/firebird25-server/pkg-install
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+# $FreeBSD: /tmp/pcvs/ports/databases/firebird25-server/files/pkg-install.in,v 1.2 2011-07-10 17:37:11 crees Exp $
+
+PATH=/bin:/usr/bin:/usr/sbin
+
+buildwarning() {
+cat <<EOF
+###############################################################################
+
+ ** IMPORTANT **
+
+Keep in mind that if you build firebird server as 'root', this may cause
+conflicts with SysV semaphores of running services.
+
+If you want to cancel it, press ctrl-C now if you need check some things
+before of build it.
+
+###############################################################################
+EOF
+ sleep 5
+}
+
+case $2 in
+PRE-INSTALL)
+ buildwarning
+;;
+POST-INSTALL)
+cd /var/db/firebird
+
+# Lock files
+
+for i in isc_init1 isc_lock1 isc_event1
+do
+ FileName=$i.`hostname`
+ touch $FileName
+ chmod uga=rw $FileName
+ chown firebird:firebird $FileName
+done
+
+touch firebird.log
+chown firebird:firebird firebird.log security2.fdb
+
+;;
+
+esac