aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-03-25 22:58:40 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-03-25 22:58:40 +0800
commitbaf88527d317fae80e7b5b01e1afe2885f867f84 (patch)
treef9f353f4f1928b5d9aa4b3742c57b31e4a1ab41a /databases
parent53283e28cedcc3d453809495b6f1ef8a9be16a66 (diff)
downloadfreebsd-ports-gnome-baf88527d317fae80e7b5b01e1afe2885f867f84.tar.gz
freebsd-ports-gnome-baf88527d317fae80e7b5b01e1afe2885f867f84.tar.zst
freebsd-ports-gnome-baf88527d317fae80e7b5b01e1afe2885f867f84.zip
- Cleanup -lpthread/-pthread manipulation
Diffstat (limited to 'databases')
-rw-r--r--databases/rocksdb/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index 36b34a5cac0f..1b3ad6e218cb 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -30,9 +30,8 @@ PROGRAMS= blob_store_bench db_bench db_repl_stress db_sanity_test \
table_reader_bench
post-patch:
- @${REINPLACE_CMD} -e '/^all: / s| $$(TESTS)||' \
- -e 's| -Werror||' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|-lpthread|-pthread|; s| -fno-builtin-memcmp||; s| -ltcmalloc||' ${WRKSRC}/build_tools/build_detect_platform
+ @${REINPLACE_CMD} -e '/^all: / s| $$(TESTS)||; s| -Werror||' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's| -fno-builtin-memcmp||; s| -ltcmalloc||' ${WRKSRC}/build_tools/build_detect_platform
@${REINPLACE_CMD} -e '/PLATFORM_IS_LITTLE_ENDIAN/ s|__|_|g' ${WRKSRC}/port/port_posix.h
.if defined(WITHOUT_PROFILE)
@${REINPLACE_CMD} -e 's| -pg||' ${WRKSRC}/Makefile