aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2005-04-22 13:41:26 +0800
committerbland <bland@FreeBSD.org>2005-04-22 13:41:26 +0800
commitbb6e44f1a6fd5a23df61d91bf52ebdbd04d85680 (patch)
treec6bc890a4c418c48748c041ecfe134a009450b86 /databases
parent4b2e3f9fa9b56c28d8bc1f6ee8825df89b39ce83 (diff)
downloadfreebsd-ports-gnome-bb6e44f1a6fd5a23df61d91bf52ebdbd04d85680.tar.gz
freebsd-ports-gnome-bb6e44f1a6fd5a23df61d91bf52ebdbd04d85680.tar.zst
freebsd-ports-gnome-bb6e44f1a6fd5a23df61d91bf52ebdbd04d85680.zip
Fix build failure triggered by pkgconfig update.
Diffstat (limited to 'databases')
-rw-r--r--databases/libgdamm/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/databases/libgdamm/Makefile b/databases/libgdamm/Makefile
index 756f6fae7c2a..8dbde0ba72bc 100644
--- a/databases/libgdamm/Makefile
+++ b/databases/libgdamm/Makefile
@@ -22,6 +22,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GCC= 3.4
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GNOME= gnomehack libgda2
USE_INC_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
@@ -36,4 +37,8 @@ patch-autotools:
${RM} $$file.tmp; \
done);
+post-patch:
+ @${REINPLACE_CMD} -e "s|\(-lglibmm\)|-L\$$(GMM_PROCDIR)/../.. \1|" \
+ ${WRKSRC}/tools/extra_defs_gen/Makefile.in
+
.include <bsd.port.mk>