aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-08-30 13:26:46 +0800
committerlioux <lioux@FreeBSD.org>2001-08-30 13:26:46 +0800
commitdaa88ff1968648857d1f55933b32d49055fa8848 (patch)
treec76ce63e71201f4fa723fda7479c9593508723ce /databases
parent623c20940e8839af775d272028785ceec8214d0f (diff)
downloadfreebsd-ports-gnome-daa88ff1968648857d1f55933b32d49055fa8848.tar.gz
freebsd-ports-gnome-daa88ff1968648857d1f55933b32d49055fa8848.tar.zst
freebsd-ports-gnome-daa88ff1968648857d1f55933b32d49055fa8848.zip
o add NO_BUILD instead of an empty do-build target
o unecho some commands in Makefile o support NOPORTDOCS in PLIST PR: 29797 Submitted by: Patrick Li <pat@databits.net>, bento
Diffstat (limited to 'databases')
-rw-r--r--databases/gadfly/Makefile12
-rw-r--r--databases/gadfly/pkg-plist20
2 files changed, 15 insertions, 17 deletions
diff --git a/databases/gadfly/Makefile b/databases/gadfly/Makefile
index fbe56dca89c9..cb3430fcf5e7 100644
--- a/databases/gadfly/Makefile
+++ b/databases/gadfly/Makefile
@@ -15,11 +15,9 @@ MAINTAINER= ports@FreeBSD.org
USE_PYTHON= yes
NO_WRKSUBDIR= yes
+NO_BUILD= yes
GADFLYDIR= ${PYTHON_SITELIBDIR}/gadfly
-GADFLYDOCDIR= ${PREFIX}/share/doc/gadfly
-
-do-build:
do-install:
${MKDIR} ${GADFLYDIR}
@@ -29,11 +27,11 @@ do-install:
(cd ${GADFLYDIR}; ${PYTHON_CMD} gfinstall.py)
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${GADFLYDIR}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${GADFLYDIR}
- ${MKDIR} ${GADFLYDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${GADFLYDOCDIR}
.if !defined(${NOPORTDOCS})
- ${INSTALL_DATA} ${WRKSRC}/*.html ${GADFLYDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/gadfly.JPG ${GADFLYDOCDIR}
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/gadfly.JPG ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/databases/gadfly/pkg-plist b/databases/gadfly/pkg-plist
index 5c5bf3e67049..a378df7b2c17 100644
--- a/databases/gadfly/pkg-plist
+++ b/databases/gadfly/pkg-plist
@@ -84,14 +84,14 @@ lib/%%PYTHON_VERSION%%/site-packages/gadfly/sqlsem.pyo
lib/%%PYTHON_VERSION%%/site-packages/gadfly/sqlwhere.py
lib/%%PYTHON_VERSION%%/site-packages/gadfly/sqlwhere.pyc
lib/%%PYTHON_VERSION%%/site-packages/gadfly/sqlwhere.pyo
-share/doc/gadfly/COPYRIGHT
-share/doc/gadfly/gadfly.JPG
-share/doc/gadfly/gadfly.html
-share/doc/gadfly/gfSQL.html
-share/doc/gadfly/gffaq.html
-share/doc/gadfly/gfrecover.html
-share/doc/gadfly/index.html
-share/doc/gadfly/kwParsing.html
-share/doc/gadfly/server.html
-@dirrm share/doc/gadfly
+%%PORTDOCS%%share/doc/gadfly/COPYRIGHT
+%%PORTDOCS%%share/doc/gadfly/gadfly.JPG
+%%PORTDOCS%%share/doc/gadfly/gadfly.html
+%%PORTDOCS%%share/doc/gadfly/gfSQL.html
+%%PORTDOCS%%share/doc/gadfly/gffaq.html
+%%PORTDOCS%%share/doc/gadfly/gfrecover.html
+%%PORTDOCS%%share/doc/gadfly/index.html
+%%PORTDOCS%%share/doc/gadfly/kwParsing.html
+%%PORTDOCS%%share/doc/gadfly/server.html
+%%PORTDOCS%%@dirrm share/doc/gadfly
@dirrm lib/%%PYTHON_VERSION%%/site-packages/gadfly