aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2013-11-07 06:50:21 +0800
committerdelphij <delphij@FreeBSD.org>2013-11-07 06:50:21 +0800
commite152fec3d3565ef13abcbeb42f37c47f2788e9ca (patch)
treef4ca39f0f94b1fc725562cca278474e325706ee3 /databases
parent43af442547bb63fc6c7117fbc9d483374293c063 (diff)
downloadfreebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.tar.gz
freebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.tar.zst
freebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.zip
Update to 0.57.
PR: ports/179390 Submitted by: nemysis Approved by: maintainer
Diffstat (limited to 'databases')
-rw-r--r--databases/pure-sql3/Makefile27
-rw-r--r--databases/pure-sql3/pkg-descr2
2 files changed, 25 insertions, 4 deletions
diff --git a/databases/pure-sql3/Makefile b/databases/pure-sql3/Makefile
index de1b78bbbda6..5b630188172c 100644
--- a/databases/pure-sql3/Makefile
+++ b/databases/pure-sql3/Makefile
@@ -3,19 +3,40 @@
PORTNAME= pure-sql3
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
+MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
COMMENT= Pure language binding to the SQLite3 library
+LICENSE= BSD
+
LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
-USE_PURE= yes
+USES= pure
PLIST_FILES= lib/pure/sql3.pure \
lib/pure/sql3util.so
NO_STAGE= yes
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
+
+PORTDOCS= README
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/databases/pure-sql3/pkg-descr b/databases/pure-sql3/pkg-descr
index 2d2a6d8edbfc..5fff5c4b6334 100644
--- a/databases/pure-sql3/pkg-descr
+++ b/databases/pure-sql3/pkg-descr
@@ -3,4 +3,4 @@ minimal wrapper around Sqlite3's C interface which is designed to give the
developer access to all of Sqlite3's features in a way that is convenient
for Pure programmers.
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-sql3.html
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-sql3.html