aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2015-07-29 20:15:48 +0800
committerwen <wen@FreeBSD.org>2015-07-29 20:15:48 +0800
commitecb0dcfeaf867272c8b7a91323b2d6a40c0346f3 (patch)
tree7b87cd9212744d2eece39202f21a5c60fff66251 /databases
parent5a73c975f4215624d58080e6c825bd1c12407cc2 (diff)
downloadfreebsd-ports-gnome-ecb0dcfeaf867272c8b7a91323b2d6a40c0346f3.tar.gz
freebsd-ports-gnome-ecb0dcfeaf867272c8b7a91323b2d6a40c0346f3.tar.zst
freebsd-ports-gnome-ecb0dcfeaf867272c8b7a91323b2d6a40c0346f3.zip
- Update to 6.4.5
PR: 201838 Submitted by: tkato432@yahoo.com
Diffstat (limited to 'databases')
-rw-r--r--databases/grass/Makefile34
-rw-r--r--databases/grass/distinfo4
2 files changed, 22 insertions, 16 deletions
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index a7248957fe1c..0d6c5cae78bc 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= grass
-PORTVERSION= 6.4.4
-PORTREVISION= 6
+PORTVERSION= 6.4.5
PORTEPOCH= 2
CATEGORIES= databases geography
MASTER_SITES= http://grass.osgeo.org/%SUBDIR%/ \
@@ -22,7 +21,8 @@ MASTER_SITE_SUBDIR= grass64/source
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source Geographical Information System (GIS)
-LICENSE= GPLv2
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/GPL.TXT
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
@@ -33,8 +33,8 @@ LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= fortran gettext gmake iconv jpeg perl5 pkgconfig python:2 readline \
- shebangfix tk
+USES= fortran gettext gmake iconv jpeg perl5 pkgconfig python:2 \
+ readline shebangfix tk
SHEBANG_FILES= scripts/i.spectral/i.spectral \
scripts/r.tileset/r.tileset
PATCH_TCL_SCRIPTS=lib/init/init.sh
@@ -74,13 +74,16 @@ PLIST_SUB= GRASS_INST_DIR="${GRASS_INST_DIR}" \
BROKEN_sparc64= Does not configure on sparc64
-OPTIONS_DEFINE= ATLAS FFMPEG MOTIF MYSQL ODBC PGSQL SQLITE
+OPTIONS_DEFINE= ATLAS FFMPEG MOTIF
+OPTIONS_MULTI= DB
+OPTIONS_MULTI_DB= MYSQL ODBC PGSQL SQLITE
OPTIONS_DEFAULT= PGSQL
OPTIONS_SUB= yes
ATLAS_DESC= Use ATLAS for BLAS and LAPACK
ATLAS_USES= blaslapack:atlas
ATLAS_USES_OFF= blaslapack
+DB_DESC= Database support
FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
FFMPEG_CONFIGURE_ON= --with-ffmpeg \
--with-ffmpeg-includes="${LOCALBASE}/include/libavcodec \
@@ -108,12 +111,12 @@ SQLITE_CONFIGURE_ON= --with-sqlite
GRASS_INST_DIR= ${PORTNAME}-${PORTVERSION}
.endif
-pre-configure:
- ${REINPLACE_CMD} -e \
- 's|-lblas|${BLASLIB}| ; \
- s|-llapack|${LAPACKLIB}| ; \
- s|g2c|f2c|' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e \
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lblas|${BLASLIB}|g ; \
+ s|-llapack|${LAPACKLIB}|g ; \
+ s|g2c|f2c|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
's|make -C|$$(MAKE) -C| ; \
/^BINDIR/s|=.*|= $${DESTDIR}$${UNIX_BIN}| ; \
/test /s| $${INST_DIR}| $${DESTDIR}$${INST_DIR}|g ; \
@@ -121,10 +124,10 @@ pre-configure:
/chmod /s| $${INST_DIR}| $${DESTDIR}$${INST_DIR}|g ; \
/tar /s| $${INST_DIR}| $${DESTDIR}$${INST_DIR}|g ; \
s|> $${INST_DIR}|> $${DESTDIR}$${INST_DIR}|' ${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e \
's|^CC=.*|CC?=cc| ; \
s|^CFLAGS=.*|CFLAGS+=-fno-common|' ${WRKSRC}/gem/Makefile
- ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e \
's|= python|= ${PYTHON_CMD:T}|' ${WRKSRC}/include/Make/Platform.make.in
post-install:
@@ -145,4 +148,7 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/lib/libgrass_*.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/tools/g.echo
+post-install-MOTIF-on:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${GRASS_INST_DIR}/bin/xganim
+
.include <bsd.port.mk>
diff --git a/databases/grass/distinfo b/databases/grass/distinfo
index fac73fd5f4b8..9f25f8225b59 100644
--- a/databases/grass/distinfo
+++ b/databases/grass/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grass-6.4.4.tar.gz) = 5ddba27b4e5495f602ee5249a07e287f342dd8e1422ea5d490c04311c731d274
-SIZE (grass-6.4.4.tar.gz) = 25643959
+SHA256 (grass-6.4.5.tar.gz) = f501da62807eb08efcb85820859fe5ade9bc392e20641b606273c956bb678f3e
+SIZE (grass-6.4.5.tar.gz) = 25662709