aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-10-22 11:19:13 +0800
committerdanilo <danilo@FreeBSD.org>2013-10-22 11:19:13 +0800
commitfb9643a7c6ad3eebe9cdf895468a426d381a23cd (patch)
tree46ceff5419e388d816aa6f508777467185fcc9db /databases
parentd16249f2479d4369f0ce9146c4ef2adda2e8cf5e (diff)
downloadfreebsd-ports-gnome-fb9643a7c6ad3eebe9cdf895468a426d381a23cd.tar.gz
freebsd-ports-gnome-fb9643a7c6ad3eebe9cdf895468a426d381a23cd.tar.zst
freebsd-ports-gnome-fb9643a7c6ad3eebe9cdf895468a426d381a23cd.zip
- Convert {BUILD,RUN}_DEPENDS to USE_PGSQL [1]
- Add LICENSE - Convert USE_GMAKE to USES - Add DOCS option - Add stage support PR: ports/183166 Submitted by: Alexander Pyhalov <alp@sfedu.ru> (maintainer) [1]
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-repmgr/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/databases/postgresql-repmgr/Makefile b/databases/postgresql-repmgr/Makefile
index 52bf95ac835b..ae636780ab74 100644
--- a/databases/postgresql-repmgr/Makefile
+++ b/databases/postgresql-repmgr/Makefile
@@ -10,27 +10,26 @@ DISTNAME= repmgr-${PORTVERSION}
MAINTAINER= alp@sfedu.ru
COMMENT= PostgreSQL replication manager
-BUILD_DEPENDS= postgresql-server>=9.0:${PORTSDIR}/databases/postgresql90-server
-RUN_DEPENDS:= ${BUILD_DEPENDS} \
- rsync:${PORTSDIR}/net/rsync
+LICENSE= GPLv3
-USE_GMAKE= yes
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+
+USES= gmake
+USE_PGSQL= yes
+WANT_PGSQL_VER= 90+
MAKE_ENV= USE_PGXS=1
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= README.*
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/repmgr ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/repmgrd ${PREFIX}/sbin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.rst ${DOCSDIR}
-.endif
-.if !defined(NOPORTDATA)
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/repmgr.conf ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/repmgr.sql ${DATADIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/repmgr ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/repmgrd ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/repmgr.conf ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/repmgr.sql ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>