aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/adesklets
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-03-15 06:46:22 +0800
committerpav <pav@FreeBSD.org>2008-03-15 06:46:22 +0800
commit70b2b2baf5981a47639c6925fb8fec456d1b389a (patch)
treedda26a6484352ee233e291e6d09e53ebcc5f2ad2 /deskutils/adesklets
parente338dff046c281779a30c98b86219957d8de7c39 (diff)
downloadfreebsd-ports-gnome-70b2b2baf5981a47639c6925fb8fec456d1b389a.tar.gz
freebsd-ports-gnome-70b2b2baf5981a47639c6925fb8fec456d1b389a.tar.zst
freebsd-ports-gnome-70b2b2baf5981a47639c6925fb8fec456d1b389a.zip
(Committing on behalf of stas)
- Fix adesklets breakage after an imlib2 update. Somehow, it started to detect iconv installed, but fails to link the binary properly. Also fix some other configure syntax errors. Pointy hat to: me (for not testing everything before commit) Reported by: pav, erwin
Diffstat (limited to 'deskutils/adesklets')
-rw-r--r--deskutils/adesklets/Makefile2
-rw-r--r--deskutils/adesklets/files/patch-configure50
2 files changed, 50 insertions, 2 deletions
diff --git a/deskutils/adesklets/Makefile b/deskutils/adesklets/Makefile
index fbd5b32828bc..8255c1931f27 100644
--- a/deskutils/adesklets/Makefile
+++ b/deskutils/adesklets/Makefile
@@ -23,6 +23,7 @@ USE_GMAKE= yes
USE_BZIP2= yes
USE_XLIB= yes
USE_EFL= imlib2
+USE_ICONV= yes
WANT_PERL= yes
MAN1= adesklets.1 \
@@ -34,6 +35,7 @@ INFO= adesklets \
SUB_FILES= pkg-message
INSTALLS_EGGINFO= yes
+LDFLAGS+= -liconv
.if !defined(WITHOUT_PERL)
USE_PERL5= yes
diff --git a/deskutils/adesklets/files/patch-configure b/deskutils/adesklets/files/patch-configure
index 96fc0c3d7722..b8915ff11115 100644
--- a/deskutils/adesklets/files/patch-configure
+++ b/deskutils/adesklets/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2006-03-31 03:19:07.000000000 +0200
-+++ configure 2007-12-21 21:37:27.000000000 +0100
+--- configure.orig 2006-03-31 05:19:07.000000000 +0400
++++ configure 2008-03-15 00:14:53.000000000 +0300
@@ -5352,7 +5352,8 @@
UNAME_REDUX=`uname -r -s | sed 's/\..*//' 2> /dev/null`
if test "$UNAME_REDUX" != 'FreeBSD 5' && \
@@ -10,3 +10,49 @@
then
cat >>confdefs.h <<\_ACEOF
+@@ -6735,13 +6736,13 @@
+ echo "${ECHO_T}no" >&6
+ fi
+
+-if ! test x$PKG_CONFIG = "x" ; then
++if ! test "x$PKG_CONFIG" = "x" ; then
+ if $PKG_CONFIG --exists fontconfig 2> /dev/null; then
+ FONTCONFIG_LIBS=`pkg-config --libs fontconfig`
+ FONTCONFIG_CFLAGS=`pkg-config --cflags fontconfig`
+ fi
+ fi
+-if test x$FONTCONFIG_LIBS = "x"; then
++if test "x$FONTCONFIG_LIBS" = "x"; then
+ FONTCONFIG_LIBS=-lfontconfig
+ fi
+ LIBS="$LIBS $FONTCONFIG_LIBS"
+@@ -7367,11 +7368,11 @@
+ IMLIB2_LIBS="`$IMLIB2_CONFIG $imlib2_config_args --libs`"
+
+ imlib2_config_major_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+).*/\1/'`
+ imlib2_config_minor_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+).*/\2/'`
+ imlib2_config_micro_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+)\.([0-9]+).*/\3/'`
+ imlib2_wanted_major_version="1"
+ imlib2_wanted_minor_version="1"
+ imlib2_wanted_micro_version="2"
+@@ -7441,11 +7442,11 @@
+ echo $ECHO_N "checking for imlib2 - version >= 1.2.0... $ECHO_C" >&6
+
+ imlib2_config_major_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+).*/\1/'`
+ imlib2_config_minor_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+).*/\2/'`
+ imlib2_config_micro_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+)\.([0-9]+).*/\3/'`
+ imlib2_wished_major_version="1"
+ imlib2_wished_minor_version="2"
+ imlib2_wished_micro_version="0"