aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/akamaru
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-10-14 17:13:38 +0800
committermarcus <marcus@FreeBSD.org>2006-10-14 17:13:38 +0800
commit13969ac39bc2ba9905f82f0609a1e900590688d8 (patch)
treec901a2ac374ffc64eee337126fbc2777dfe95d3b /deskutils/akamaru
parentfb30ee5161b7c15b6e6ccfc57e179953cd4756a6 (diff)
downloadfreebsd-ports-gnome-13969ac39bc2ba9905f82f0609a1e900590688d8.tar.gz
freebsd-ports-gnome-13969ac39bc2ba9905f82f0609a1e900590688d8.tar.zst
freebsd-ports-gnome-13969ac39bc2ba9905f82f0609a1e900590688d8.zip
Add akamaru, a physics engine prototype.
Akamaru is a simple, but fun, physics engine prototype. It's named after the super awesome ninja dog, Akamaru, from the Naruto anime and based on the article Advanced Character Physics by Thomas Jakobsen on Verlet integration. It contains a very cool dock, called kiba. Submitted by: Phillip Neumann <pneumann@gmail.com> Approved by: portmgr (implicit, kris)
Diffstat (limited to 'deskutils/akamaru')
-rw-r--r--deskutils/akamaru/Makefile43
-rw-r--r--deskutils/akamaru/distinfo3
-rw-r--r--deskutils/akamaru/files/patch-Makefile19
-rw-r--r--deskutils/akamaru/files/patch-populate-dock.sh27
-rw-r--r--deskutils/akamaru/pkg-descr6
-rw-r--r--deskutils/akamaru/pkg-plist4
6 files changed, 102 insertions, 0 deletions
diff --git a/deskutils/akamaru/Makefile b/deskutils/akamaru/Makefile
new file mode 100644
index 000000000000..8ab5c905bc84
--- /dev/null
+++ b/deskutils/akamaru/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: akamaru
+# Date created: 2006 10 10
+# Whom: Phillip Neumann <pneumann@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= akamaru
+PORTVERSION= 0.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://people.freedesktop.org/~krh/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= pneumann@gmail.com
+COMMENT= Simple, but fun, physics engine prototype
+
+BUILD_DEPENDS= gtk-demo:${PORTSDIR}/x11-toolkits/gtk20
+RUN_DEPENDS= gtk-demo:${PORTSDIR}/x11-toolkits/gtk20 \
+ xcompmgr:${PORTSDIR}/x11-wm/xcompmgr
+
+USE_GMAKE= yes
+USE_GNOME= gconf2 gnomehier
+GCONF_SCHEMAS= kiba.schemas
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/populate-dock.sh
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/dock ${PREFIX}/bin/kiba-dock
+ @${INSTALL_PROGRAM} ${WRKSRC}/akamaru ${PREFIX}/bin/akamaru
+ @${INSTALL_DATA} ${WRKSRC}/kiba.schemas ${LOCALBASE}/etc/gconf/schemas
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+ @${INSTALL_SCRIPT} ${WRKSRC}/populate-dock.sh ${PREFIX}/share/${PORTNAME}
+ @${SETENV} GCONF_CONFIG_SOURCE=${GCONF_CONFIG_SOURCE} gconftool-2 --makefile-install-rule ${PREFIX}/etc/gconf/schemas/kiba.schemas
+
+post-install:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "*** By default kiba-dock is empty."
+ @${ECHO_MSG} "*** To add launchers, look and run the script ${PREFIX}/share/${PORTNAME}/populate-dock.sh"
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/deskutils/akamaru/distinfo b/deskutils/akamaru/distinfo
new file mode 100644
index 000000000000..94d5a24ec532
--- /dev/null
+++ b/deskutils/akamaru/distinfo
@@ -0,0 +1,3 @@
+MD5 (akamaru.tar.gz) = 3c99aa59c4b076a19de509a32ba5ce8a
+SHA256 (akamaru.tar.gz) = 1674e84e63711807e2fe3e965d663abc5e45fc7aa30eabff0dc294137c227c7c
+SIZE (akamaru.tar.gz) = 19319
diff --git a/deskutils/akamaru/files/patch-Makefile b/deskutils/akamaru/files/patch-Makefile
new file mode 100644
index 000000000000..2fe8ad307bf1
--- /dev/null
+++ b/deskutils/akamaru/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Sun Jul 16 01:37:05 2006
++++ Makefile Wed Oct 11 01:04:51 2006
+@@ -4,7 +4,7 @@
+ LDFLAGS = -g
+ GCONFTOOL = gconftool-2
+
+-prefix = $(HOME)
++prefix = $(PREFIX)
+ targets = akamaru dock
+ schemas = kiba.schemas
+ akamaru_objs = main.o akamaru.o
+@@ -25,6 +25,7 @@
+
+ install : install-schemas
+ install dock $(prefix)/bin/kiba-dock
++ install akamaru $(prefix)/bin/akamaru
+ sh populate-dock.sh
+
+ uninstall-schemas : gconf-clean
diff --git a/deskutils/akamaru/files/patch-populate-dock.sh b/deskutils/akamaru/files/patch-populate-dock.sh
new file mode 100644
index 000000000000..7b7a206d3754
--- /dev/null
+++ b/deskutils/akamaru/files/patch-populate-dock.sh
@@ -0,0 +1,27 @@
+--- populate-dock.sh.orig Sun Jul 16 01:37:05 2006
++++ populate-dock.sh Wed Oct 11 22:29:57 2006
+@@ -3,18 +3,16 @@
+ # Simple shell script to populate the dock by setting up some random
+ # standard applications.
+
+-make install-schemas
++GAPPs=/usr/local/share/gnome/applications
++APPs=/usr/local/share/applications
+
+ while read n file; do
+ key=/apps/kiba/launchers/$n/file
+ gconftool-2 --set $key --type string $file
+ gconftool-2 --apply-schema /schemas/apps/kiba/launchers/file $key
+ done <<EOF
+- 0 /usr/share/applications/gnome-terminal.desktop
+- 1 /usr/share/applications/gimp-2.2.desktop
+- 2 /usr/share/applications/epiphany.desktop
+- 3 /usr/share/applications/gaim.desktop
+- 4 /usr/share/applications/gnome-cd.desktop
+- 5 /usr/share/applications/background.desktop
+- 6 /usr/share/applications/gnome-file-roller.desktop
++ 0 $GAPPs/gnome-terminal.desktop
++ 1 $GAPPs/gedit.desktop
++ 2 $APPs/firefox.desktop
++ 3 $GAPPs/evolution-2.8.desktop
+ EOF
diff --git a/deskutils/akamaru/pkg-descr b/deskutils/akamaru/pkg-descr
new file mode 100644
index 000000000000..cc36ec8fd1c0
--- /dev/null
+++ b/deskutils/akamaru/pkg-descr
@@ -0,0 +1,6 @@
+Akamaru is a simple, but fun, physics engine prototype. It's named after the
+super awesome ninja dog, Akamaru, from the Naruto anime and based on the
+article Advanced Character Physics by Thomas Jakobsen on Verlet integration.
+It contains a very cool dock, called kiba.
+
+WWW: http://people.freedesktop.org/~krh/akamaru.git/
diff --git a/deskutils/akamaru/pkg-plist b/deskutils/akamaru/pkg-plist
new file mode 100644
index 000000000000..76deecb9c868
--- /dev/null
+++ b/deskutils/akamaru/pkg-plist
@@ -0,0 +1,4 @@
+bin/kiba-dock
+bin/akamaru
+share/akamaru/populate-dock.sh
+@dirrm share/akamaru