aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/buoh
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-12-11 14:52:36 +0800
committermezz <mezz@FreeBSD.org>2005-12-11 14:52:36 +0800
commit573f15ee9052a712e75a97a5a54574b6fa404749 (patch)
tree030df44c83ac7b9e9320fc360cefe34e18539acd /deskutils/buoh
parent51ab7c928f7fb08747cae463a3a74ba1adfac3d6 (diff)
downloadfreebsd-ports-gnome-573f15ee9052a712e75a97a5a54574b6fa404749.tar.gz
freebsd-ports-gnome-573f15ee9052a712e75a97a5a54574b6fa404749.tar.zst
freebsd-ports-gnome-573f15ee9052a712e75a97a5a54574b6fa404749.zip
Add g_mutex_unlock() to solve the dump core at exit. I am not sure if it is a
right way to do it, but at least no more crash for now. Later, the correct way will be come up if I get any respone. Bump the PORTREVISION.
Diffstat (limited to 'deskutils/buoh')
-rw-r--r--deskutils/buoh/Makefile1
-rw-r--r--deskutils/buoh/files/patch-src_buoh-comic-loader.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/deskutils/buoh/Makefile b/deskutils/buoh/Makefile
index 56eaa654b4a0..df48a09340b6 100644
--- a/deskutils/buoh/Makefile
+++ b/deskutils/buoh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= buoh
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= deskutils www gnome
MASTER_SITES= http://buoh.steve-o.org/downloads/
diff --git a/deskutils/buoh/files/patch-src_buoh-comic-loader.c b/deskutils/buoh/files/patch-src_buoh-comic-loader.c
new file mode 100644
index 000000000000..6133d783e0de
--- /dev/null
+++ b/deskutils/buoh/files/patch-src_buoh-comic-loader.c
@@ -0,0 +1,10 @@
+--- src/buoh-comic-loader.c.orig Sun Dec 11 00:25:18 2005
++++ src/buoh-comic-loader.c Sun Dec 11 00:25:39 2005
+@@ -184,6 +184,7 @@
+ }
+
+ if (loader->thread_mutex) {
++ g_mutex_unlock (loader->thread_mutex);
+ g_mutex_free (loader->thread_mutex);
+ loader->thread_mutex = NULL;
+ }