aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/buoh
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-12-12 14:40:22 +0800
committermezz <mezz@FreeBSD.org>2005-12-12 14:40:22 +0800
commit353b9206b9f7689383bf3cf4e4dbd57ea78539e4 (patch)
tree4ea9bc430f0721711f46f73f5d3040ae91546b07 /deskutils/buoh
parent7d940eb3cdae20aeca8659b5c952a465cd9b9f63 (diff)
downloadfreebsd-ports-gnome-353b9206b9f7689383bf3cf4e4dbd57ea78539e4.tar.gz
freebsd-ports-gnome-353b9206b9f7689383bf3cf4e4dbd57ea78539e4.tar.zst
freebsd-ports-gnome-353b9206b9f7689383bf3cf4e4dbd57ea78539e4.zip
Add WITH_DEBUG option to enable the debug.
Diffstat (limited to 'deskutils/buoh')
-rw-r--r--deskutils/buoh/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/deskutils/buoh/Makefile b/deskutils/buoh/Makefile
index df48a09340b6..63de6b9a7c5d 100644
--- a/deskutils/buoh/Makefile
+++ b/deskutils/buoh/Makefile
@@ -25,6 +25,19 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
GCONF_SCHEMAS= buoh.schemas
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+CFLAGS+= -g
+STRIP=
+.endif
+
+pre-everything::
+.if !defined(WITH_DEBUG)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "WITH_DEBUG=yes to enable debugging in Buoh."
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/applications|g' \
${WRKSRC}/data/Makefile.in