aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/calibre
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-01-18 05:28:35 +0800
committermadpilot <madpilot@FreeBSD.org>2015-01-18 05:28:35 +0800
commit69f8fd56a0ca789c7800a47c268f0c4ec5a680ab (patch)
tree9fb8fbe3aca6da2a1ed97b0ab572bca3e3e8585a /deskutils/calibre
parent817e01f6c8323262877b8d5a01a4e7b966525084 (diff)
downloadfreebsd-ports-gnome-69f8fd56a0ca789c7800a47c268f0c4ec5a680ab.tar.gz
freebsd-ports-gnome-69f8fd56a0ca789c7800a47c268f0c4ec5a680ab.tar.zst
freebsd-ports-gnome-69f8fd56a0ca789c7800a47c268f0c4ec5a680ab.zip
- Fix .desktop entries [1]
While here: - Don't create unneeded empty directories - Silence one installation command PR: 196817 [1] Submitted by: Lawrence Chen <beastie at tardisi.com>
Diffstat (limited to 'deskutils/calibre')
-rw-r--r--deskutils/calibre/Makefile8
-rw-r--r--deskutils/calibre/files/patch-calibre_linux.py35
2 files changed, 35 insertions, 8 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 53b078929b84..e2f248ff2c14 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -3,7 +3,7 @@
PORTNAME= calibre
PORTVERSION= 1.48.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
@@ -79,14 +79,14 @@ do-build:
${PYSETUP} build)
do-install:
-.for dir in bash-completion desktop-directories gnome/apps mime/packages \
- icons/hicolor/128x128/apps zsh/site-functions
+.for dir in bash-completion gnome/apps mime/packages \
+ icons/hicolor/128x128 zsh/site-functions
${MKDIR} ${STAGEDIR}${PREFIX}/share/${dir}
.endfor
${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
${PYSETUP} install --prefix ${PREFIX} \
--staging-root ${STAGEDIR}${PREFIX})
- ${RM} ${STAGEDIR}${PREFIX}/bin/calibre-uninstall
+ @${RM} ${STAGEDIR}${PREFIX}/bin/calibre-uninstall
.include <bsd.port.mk>
diff --git a/deskutils/calibre/files/patch-calibre_linux.py b/deskutils/calibre/files/patch-calibre_linux.py
index 97b7cd82e7d0..7d3eb772b656 100644
--- a/deskutils/calibre/files/patch-calibre_linux.py
+++ b/deskutils/calibre/files/patch-calibre_linux.py
@@ -1,6 +1,6 @@
---- src/calibre/linux.py.orig 2014-02-09 13:42:40.000000000 -0600
-+++ src/calibre/linux.py 2014-02-09 13:43:59.000000000 -0600
-@@ -712,6 +712,7 @@
+--- src/calibre/linux.py.orig 2014-08-08 03:21:35 UTC
++++ src/calibre/linux.py
+@@ -831,6 +831,7 @@ class PostInstall:
f.close()
des = ('calibre-gui.desktop', 'calibre-lrfviewer.desktop',
'calibre-ebook-viewer.desktop', 'calibre-ebook-edit.desktop')
@@ -8,7 +8,7 @@
appdata = os.path.join(os.path.dirname(self.opts.staging_sharedir), 'appdata')
if not os.path.exists(appdata):
try:
-@@ -726,8 +727,10 @@
+@@ -845,8 +846,10 @@ class PostInstall:
APPDATA = get_appdata()
for x in des:
@@ -21,3 +21,30 @@
self.menu_resources.append(x)
ak = x.partition('.')[0]
if ak in APPDATA and os.access(appdata, os.W_OK):
+@@ -992,7 +995,7 @@ Name=E-book Viewer
+ GenericName=Viewer for E-books
+ Comment=Viewer for E-books in all the major formats
+ TryExec=ebook-viewer
+-Exec=ebook-viewer --detach %f
++Exec=ebook-viewer %f
+ Icon=calibre-viewer
+ Categories=Graphics;Viewer;
+ '''
+@@ -1005,7 +1008,7 @@ Name=Edit E-book
+ GenericName=Edit E-books
+ Comment=Edit e-books in various formats
+ TryExec=ebook-edit
+-Exec=ebook-edit --detach %f
++Exec=ebook-edit %f
+ Icon=calibre-ebook-edit
+ Categories=Office;
+ '''
+@@ -1018,7 +1021,7 @@ Name=calibre
+ GenericName=E-book library management
+ Comment=E-book library management: Convert, view, share, catalogue all your e-books
+ TryExec=calibre
+-Exec=calibre --detach %F
++Exec=calibre %F
+ Icon=calibre-gui
+ Categories=Office;
+ '''