aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/calibre
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-10-31 17:53:19 +0800
committerkwm <kwm@FreeBSD.org>2011-10-31 17:53:19 +0800
commite023fa413a2b5c92e3a25b68a938aafee6c8f0df (patch)
tree815ee3eb76f1fbeac96aba420506706d87f0dc44 /deskutils/calibre
parentb76f21ecd341615f5c842d25b0e04db00f826db2 (diff)
downloadfreebsd-ports-gnome-e023fa413a2b5c92e3a25b68a938aafee6c8f0df.tar.gz
freebsd-ports-gnome-e023fa413a2b5c92e3a25b68a938aafee6c8f0df.tar.zst
freebsd-ports-gnome-e023fa413a2b5c92e3a25b68a938aafee6c8f0df.zip
Update poppler to 0.18.0.
The qt3 bindings are removed upstream. The glib library lost the last gdk-pixbuf code. And rename it from -gtk to -glib. Thanks to: pav for a exp-runs bapt for double checking the libreoffice ports
Diffstat (limited to 'deskutils/calibre')
-rw-r--r--deskutils/calibre/Makefile1
-rw-r--r--deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.cpp14
-rw-r--r--deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.h14
3 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index f307cb7bcbb0..73ae50694866 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -7,6 +7,7 @@
PORTNAME= calibre
PORTVERSION= 0.8.21
+PORTREVISION= 1
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
diff --git a/deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.cpp b/deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.cpp
new file mode 100644
index 000000000000..9f13078ba714
--- /dev/null
+++ b/deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.cpp
@@ -0,0 +1,14 @@
+--- src/calibre/ebooks/pdf/reflow.cpp.orig 2011-10-26 01:52:43.000000000 +0000
++++ src/calibre/ebooks/pdf/reflow.cpp 2011-10-26 12:02:17.000000000 +0000
+@@ -625,11 +625,7 @@ static string get_link_dest(LinkAction *
+ return oss.str();
+ }
+
+-#if (POPPLER_MAJOR_VERSION == 0) && (POPPLER_MINOR_VERSION < 17)
+-void XMLOutputDev::process_link(Link* link){
+-#else
+ void XMLOutputDev::process_link(AnnotLink* link){
+-#endif
+
+ double _x1, _y1, _x2, _y2;
+ int x1, y1, x2, y2;
diff --git a/deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.h b/deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.h
new file mode 100644
index 000000000000..47ab911dcd79
--- /dev/null
+++ b/deskutils/calibre/files/patch-src_calibre_ebooks_pdf_reflow.h
@@ -0,0 +1,14 @@
+--- src/calibre/ebooks/pdf/reflow.h.orig 2011-10-26 12:04:54.000000000 +0000
++++ src/calibre/ebooks/pdf/reflow.h 2011-10-26 12:09:04.000000000 +0000
+@@ -244,11 +244,7 @@ class XMLOutputDev : public OutputDev {
+ XMLImages *images;
+ PDFDoc *doc;
+
+-#if (POPPLER_MAJOR_VERSION == 0) && (POPPLER_MINOR_VERSION < 17)
+- void process_link(Link* link);
+-#else
+ void process_link(AnnotLink* link);
+-#endif
+
+ };
+ }