aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/cdcat
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-07 02:03:52 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-07 02:03:52 +0800
commit76fd2429e085d1e9dec9fe0ec9719551323b3e12 (patch)
tree4b562ddd5a1b4f7dff5c3348bad8e2e501cd88e6 /deskutils/cdcat
parent784f91f69639eeeaf013855070902bd156ecc329 (diff)
downloadfreebsd-ports-gnome-76fd2429e085d1e9dec9fe0ec9719551323b3e12.tar.gz
freebsd-ports-gnome-76fd2429e085d1e9dec9fe0ec9719551323b3e12.tar.zst
freebsd-ports-gnome-76fd2429e085d1e9dec9fe0ec9719551323b3e12.zip
cdcat is a powerful QT based tool for creating fully searcheable offline
catalogs of the contents of any arbitrary media. Primarily it is most useful for cataloging CDs, DVDs, and other such removeable media. The catalogs can be quickly searched (including across multiple catalogs) with regular expressions, exported as CSV or HTML files, sorted, and statistical information gathered. WWW: http://cdcat.sourceforge.net/ PR: ports/96828 Submitted by: Aren Tyr <aren.tyr at gawab.com>
Diffstat (limited to 'deskutils/cdcat')
-rw-r--r--deskutils/cdcat/Makefile74
-rw-r--r--deskutils/cdcat/distinfo3
-rw-r--r--deskutils/cdcat/files/patch-src-recode.cpp19
-rw-r--r--deskutils/cdcat/files/patch-src-tparser.cpp20
-rw-r--r--deskutils/cdcat/pkg-descr8
5 files changed, 124 insertions, 0 deletions
diff --git a/deskutils/cdcat/Makefile b/deskutils/cdcat/Makefile
new file mode 100644
index 000000000000..79727fda076f
--- /dev/null
+++ b/deskutils/cdcat/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: cdcat
+# Date created: 04 May 2006
+# Whom: Aren Tyr <aren.tyr@gawab.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cdcat
+PORTVERSION= 1.01b # >1.01 as b doesn't stay for 'beta'
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://cdcat.sourceforge.net/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= CdCat-${PORTVERSION}
+
+MAINTAINER= aren.tyr@gawab.com
+COMMENT= A QT based tool for offline CD/DVD/disk catalogs
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+WRKSRC= ${WRKDIR}/CdCat-${PORTVERSION}/src
+
+USE_BZIP2= yes
+USE_QT_VER= 3
+QTDIR?= ${X11BASE}
+USE_GMAKE= yes
+MAKE_ENV= QTDIR="${QTDIR}" MAKE="${GMAKE}" \
+ QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++"
+
+#PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+PLIST_FILES= bin/cdcat \
+ share/cdcat/Authors \
+ share/cdcat/COPYING \
+ share/cdcat/ChangeLog \
+ share/cdcat/README \
+ share/cdcat/TRANSLATORS_README \
+ share/cdcat/cdcat.png \
+ share/cdcat/translations/cdcat_cz.qm \
+ share/cdcat/translations/cdcat_de.qm \
+ share/cdcat/translations/cdcat_el.qm \
+ share/cdcat/translations/cdcat_es.qm \
+ share/cdcat/translations/cdcat_fr.qm \
+ share/cdcat/translations/cdcat_hu.qm \
+ share/cdcat/translations/cdcat_id.qm \
+ share/cdcat/translations/cdcat_it.qm \
+ share/cdcat/translations/cdcat_pl.qm \
+ share/cdcat/translations/cdcat_pt.qm \
+ share/cdcat/translations/cdcat_sk.qm \
+ share/cdcat/translations/cdcat_sr.qm
+PLIST_DIRS= share/cdcat/translations \
+ share/cdcat
+
+pre-configure:
+ cd ${WRKSRC} && ${MAKE_ENV} qmake cdcat.pro
+.if defined(WITH_KDE)
+PLIST_DIRS+= share/apps/cdcat
+PLIST_FILES+= share/applications/kde/cdcat.desktop \
+ share/apps/cdcat/cdcat.png
+.endif
+
+post-install:
+.if defined(WITH_KDE)
+ ${INSTALL_DATA} ${WRKSRC}/../KDE/cdcat.desktop ${LOCALBASE}/share/applications/kde
+ ${MKDIR} ${LOCALBASE}/share/apps/cdcat
+ ${LN} ${LOCALBASE}/share/cdcat/cdcat.png ${LOCALBASE}/share/apps/cdcat
+.endif
+
+ ${STRIP_CMD} ${LOCALBASE}/bin/cdcat
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/cdcat/distinfo b/deskutils/cdcat/distinfo
new file mode 100644
index 000000000000..e8251ae0a4ee
--- /dev/null
+++ b/deskutils/cdcat/distinfo
@@ -0,0 +1,3 @@
+MD5 (CdCat-1.01b.tar.bz2) = 59b321ff3848b34cb6862fd2a408cb44
+SHA256 (CdCat-1.01b.tar.bz2) = dd0a7e72115857e376234e0d926e5a8b2e256119867387e6f9f58085d65f215a
+SIZE (CdCat-1.01b.tar.bz2) = 341539
diff --git a/deskutils/cdcat/files/patch-src-recode.cpp b/deskutils/cdcat/files/patch-src-recode.cpp
new file mode 100644
index 000000000000..fd177eeb9d8c
--- /dev/null
+++ b/deskutils/cdcat/files/patch-src-recode.cpp
@@ -0,0 +1,19 @@
+*** ./recode.cpp Mon Aug 22 18:03:00 2005
+--- ../../cdcat.bsd/src/recode.cpp Sun Apr 30 19:47:51 2006
+***************
+*** 12,18 ****
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+! #include <malloc.h>
+ #include <ctype.h>
+
+ char *recode2(const char *c)
+--- 12,18 ----
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+! /* #include <malloc.h> */
+ #include <ctype.h>
+
+ char *recode2(const char *c)
diff --git a/deskutils/cdcat/files/patch-src-tparser.cpp b/deskutils/cdcat/files/patch-src-tparser.cpp
new file mode 100644
index 000000000000..07d3f8bcd515
--- /dev/null
+++ b/deskutils/cdcat/files/patch-src-tparser.cpp
@@ -0,0 +1,20 @@
+*** ./tparser.cpp Mon Sep 19 21:52:00 2005
+--- ../../cdcat.bsd/src/tparser.cpp Sun Apr 30 19:56:55 2006
+***************
+*** 27,33 ****
+ */
+ //#include <iostream.h>
+ //#include <stdio.h>
+! #include <malloc.h>
+ #include <qstring.h>
+
+ #include "tparser.h"
+--- 27,34 ----
+ */
+ //#include <iostream.h>
+ //#include <stdio.h>
+! /*#include <malloc.h> */
+! #include <stdlib.h>
+ #include <qstring.h>
+
+ #include "tparser.h"
diff --git a/deskutils/cdcat/pkg-descr b/deskutils/cdcat/pkg-descr
new file mode 100644
index 000000000000..ed603b7a595c
--- /dev/null
+++ b/deskutils/cdcat/pkg-descr
@@ -0,0 +1,8 @@
+cdcat is a powerful QT based tool for creating fully searcheable offline
+catalogs of the contents of any arbitrary media. Primarily it is most
+useful for cataloging CDs, DVDs, and other such removeable media. The
+catalogs can be quickly searched (including across multiple catalogs)
+with regular expressions, exported as CSV or HTML files, sorted, and
+statistical information gathered.
+
+WWW: http://cdcat.sourceforge.net/