aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/deskbar-applet
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-03-02 08:56:53 +0800
committermarcus <marcus@FreeBSD.org>2009-03-02 08:56:53 +0800
commit61a25a703c375d86febd45a9d5ff6e1b56e7fc84 (patch)
tree66188d85482ccaa7f212c955901d41738e498db8 /deskutils/deskbar-applet
parent5bf98f00b764359b9bfd7baf3d5c3ee22a6c9f65 (diff)
downloadfreebsd-ports-gnome-61a25a703c375d86febd45a9d5ff6e1b56e7fc84.tar.gz
freebsd-ports-gnome-61a25a703c375d86febd45a9d5ff6e1b56e7fc84.tar.zst
freebsd-ports-gnome-61a25a703c375d86febd45a9d5ff6e1b56e7fc84.zip
Attempt to fix the py-simplejson dependency. Is there no better way to
depend on a Python egg package?
Diffstat (limited to 'deskutils/deskbar-applet')
-rw-r--r--deskutils/deskbar-applet/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/deskutils/deskbar-applet/Makefile b/deskutils/deskbar-applet/Makefile
index 9771999d7846..213e08bd2055 100644
--- a/deskutils/deskbar-applet/Makefile
+++ b/deskutils/deskbar-applet/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree \
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
- ${PYTHON_SITELIBDIR}/simplejson-2.0.9-py2.5-freebsd-7.1-STABLE-i386.egg:${PORTSDIR}/devel/py-simplejson
+ ${PYTHON_SITELIBDIR}/simplejson-2.0.9-py${PYTHON_VER}-${OPSYS:L}-${_OSRELEASE}-${ARCH}.egg:${PORTSDIR}/devel/py-simplejson
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -40,6 +40,8 @@ OPTIONS= EVO "Enable evolution support" on
.include <bsd.port.pre.mk>
+_OSRELEASE!= ${UNAME} -r
+
.if !defined(WITHOUT_EVO)
USE_GNOME+= evolutiondataserver
PLIST_SUB+= EVO=""