aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/devd-notifier
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-05-12 05:01:57 +0800
committerpawel <pawel@FreeBSD.org>2012-05-12 05:01:57 +0800
commitd1b1efbe3b04308d3b700e9d56af7bc64cd672d6 (patch)
tree743a9ee14ba0e7d5f04873b4537d2b28a88d81d4 /deskutils/devd-notifier
parent623bc5e2cda83bc8e2b9c6f416ff59eeaca67fc7 (diff)
downloadfreebsd-ports-gnome-d1b1efbe3b04308d3b700e9d56af7bc64cd672d6.tar.gz
freebsd-ports-gnome-d1b1efbe3b04308d3b700e9d56af7bc64cd672d6.tar.zst
freebsd-ports-gnome-d1b1efbe3b04308d3b700e9d56af7bc64cd672d6.zip
devd-notifer - a simple daemon notifying the user about devd(8) events
with libnotify devd-notifier parses all devd(8) messages from /var/run/devd.pipe with a configurable regular expression and notifies the user about creating and destroying of device nodes. WWW: https://github.com/funglaub/devd-notifier PR: ports/166572 Submitted by: Florian Unglaub <f.unglaub@googlemail.com>
Diffstat (limited to 'deskutils/devd-notifier')
-rw-r--r--deskutils/devd-notifier/Makefile40
-rw-r--r--deskutils/devd-notifier/distinfo2
-rw-r--r--deskutils/devd-notifier/files/patch-config.mk12
-rw-r--r--deskutils/devd-notifier/pkg-descr8
4 files changed, 62 insertions, 0 deletions
diff --git a/deskutils/devd-notifier/Makefile b/deskutils/devd-notifier/Makefile
new file mode 100644
index 000000000000..9ad4f22f9604
--- /dev/null
+++ b/deskutils/devd-notifier/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: devd-notifier
+# Date created: March 30, 2012
+# Whom: Florian Unglaub <f.unglaub@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= devd-notifier
+PORTVERSION= 0.1
+CATEGORIES= deskutils
+MASTER_SITES= https://cloud.github.com/downloads/funglaub/devd-notifier/\
+ http://roladder.net/~flo/dist/
+
+MAINTAINER= f.unglaub@googlemail.com
+COMMENT= A daemon notifying the user about devd(8) events \
+ with libnotify
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
+
+MAN1= devd-notifier.1
+PLIST_FILES= bin/devd-notifier
+MANCOMPRESSED= yes
+
+pre-everything::
+ @${ECHO_MSG} "You can build devd-notifier with your own config.h using the DEVD-NOTIFIER_CONF knob:"
+ @${ECHO_MSG} "make DEVD-NOTIFIER_CONF=/path/to/devd-notifier/config.h install clean"
+
+post-extract:
+.if defined(DEVD-NOTIFIER_CONF)
+ @${ECHO_MSG} "creating config.h from ${DEVD-NOTIFIER_CONF}"
+ @${CP} ${DEVD-NOTIFIER_CONF} ${WRKSRC}/config.h
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's|/usr/local|${PREFIX}|' ${WRKSRC}/config.mk
+
+.include <bsd.port.mk>
diff --git a/deskutils/devd-notifier/distinfo b/deskutils/devd-notifier/distinfo
new file mode 100644
index 000000000000..703d944fcdb5
--- /dev/null
+++ b/deskutils/devd-notifier/distinfo
@@ -0,0 +1,2 @@
+SHA256 (devd-notifier-0.1.tar.gz) = a19a294e40587da0a12a90a2cfb54d6c3f1ed145c7401fe2e58399003e8f3b5d
+SIZE (devd-notifier-0.1.tar.gz) = 3747
diff --git a/deskutils/devd-notifier/files/patch-config.mk b/deskutils/devd-notifier/files/patch-config.mk
new file mode 100644
index 000000000000..c7731a054bb2
--- /dev/null
+++ b/deskutils/devd-notifier/files/patch-config.mk
@@ -0,0 +1,12 @@
+--- config.mk.orig 2012-05-10 00:23:31.000000000 +0200
++++ config.mk 2012-05-10 00:23:55.000000000 +0200
+@@ -11,7 +11,7 @@
+ INCS = `pkg-config --cflags libnotify`
+ LIBS = `pkg-config --libs libnotify`
+
+-CFLAGS += -std=c99 -pedantic -Wall -Os ${INCS}
+-LDFLAGS = -g ${LIBS}
++CFLAGS += -std=c99 -pedantic -Wall ${INCS}
++LDFLAGS += ${LIBS}
+
+ CC? = cc
diff --git a/deskutils/devd-notifier/pkg-descr b/deskutils/devd-notifier/pkg-descr
new file mode 100644
index 000000000000..3d1dfc378ee6
--- /dev/null
+++ b/deskutils/devd-notifier/pkg-descr
@@ -0,0 +1,8 @@
+devd-notifer - a simple daemon notifying the user about devd(8) events
+with libnotify
+
+devd-notifier parses all devd(8) messages from /var/run/devd.pipe with
+a configurable regular expression and notifies the user about creating
+and destroying of device nodes.
+
+WWW: https://github.com/funglaub/devd-notifier