aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/dosage/Makefile
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-01-28 21:05:56 +0800
committerrm <rm@FreeBSD.org>2013-01-28 21:05:56 +0800
commit7b80901a065ffbd94be2475d10cf37b4e2cc45c7 (patch)
tree201cb6342b8932eb3071352c55f1bf1c5911ba0b /deskutils/dosage/Makefile
parent9885dfa8ac7bc26c5c3d7ebbdb5b686d5ee02e76 (diff)
downloadfreebsd-ports-gnome-7b80901a065ffbd94be2475d10cf37b4e2cc45c7.tar.gz
freebsd-ports-gnome-7b80901a065ffbd94be2475d10cf37b4e2cc45c7.tar.zst
freebsd-ports-gnome-7b80901a065ffbd94be2475d10cf37b4e2cc45c7.zip
- rename py-dosage to just dosage (it's application, not library;
approved by maintainer via mail) - update to 1.8 - trim Makefile header - change WWW and MASTER_SITES to working ones PR: 175633 Submitted by: antoine (maintainer)
Diffstat (limited to 'deskutils/dosage/Makefile')
-rw-r--r--deskutils/dosage/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/dosage/Makefile b/deskutils/dosage/Makefile
new file mode 100644
index 000000000000..b6e5c3759e29
--- /dev/null
+++ b/deskutils/dosage/Makefile
@@ -0,0 +1,29 @@
+# Created by: antoine@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= dosage
+PORTVERSION= 1.8
+CATEGORIES= deskutils python
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Application to keep a local mirror of web comics
+
+LISENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests
+
+USE_GITHUB= yes
+GH_ACCOUNT= wummel
+GH_TAGNAME= upstream/${PORTVERSION}
+GH_COMMIT= eb7f7d4
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= Dosage
+
+MAN1= dosage.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man/man1|man/man1|' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>