aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/dragstack/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-06 17:22:03 +0800
committerkrion <krion@FreeBSD.org>2003-11-06 17:22:03 +0800
commit36e565bfdc2b5e2acce6557b8a9a2405496a99fd (patch)
treed0ef410ad1619081d3b08f7c699a6d733c7370f9 /deskutils/dragstack/Makefile
parentccb1925d7ae66001dfba1914b80edfbb4a0377ad (diff)
downloadfreebsd-ports-gnome-36e565bfdc2b5e2acce6557b8a9a2405496a99fd.tar.gz
freebsd-ports-gnome-36e565bfdc2b5e2acce6557b8a9a2405496a99fd.tar.zst
freebsd-ports-gnome-36e565bfdc2b5e2acce6557b8a9a2405496a99fd.zip
DragStacK, inspired by the drop stack of the PathFinder file
manager for OS X, is a KDE panel applet which provides a stack of files / resources. Files or other resources can be dropped onto the applet to add them to the stack, or dragged from the applet to remove them from the stack. PR: 58742 Submitted by: Markus Brueffer <brueffer@phoenix-systems.de>
Diffstat (limited to 'deskutils/dragstack/Makefile')
-rw-r--r--deskutils/dragstack/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/deskutils/dragstack/Makefile b/deskutils/dragstack/Makefile
new file mode 100644
index 000000000000..f83846c13be0
--- /dev/null
+++ b/deskutils/dragstack/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: dragstack
+# Date created: Thu Oct 30 23:18:04 CET 2003
+# Whom: Markus Brueffer <brueffer@phoenix-systems.de>
+#
+# $FreeBSD$
+
+PORTNAME= dragstack
+PORTVERSION= 1.1
+CATEGORIES= deskutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= brueffer@phoenix-systems.de
+COMMENT= Drop stack applet for KDE
+
+USE_KDEBASE_VER= 3
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>