aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/drivel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-02 00:59:20 +0800
committerbapt <bapt@FreeBSD.org>2012-06-02 00:59:20 +0800
commitd11c41d1ad3012decf213f15c52bcac9c1b58ccb (patch)
treee28089e70f941c688810dcf42b54dd8b8bf6ed55 /deskutils/drivel
parenta3fd2744caf5940808c561315a2f854d6a243196 (diff)
downloadfreebsd-ports-gnome-d11c41d1ad3012decf213f15c52bcac9c1b58ccb.tar.gz
freebsd-ports-gnome-d11c41d1ad3012decf213f15c52bcac9c1b58ccb.tar.zst
freebsd-ports-gnome-d11c41d1ad3012decf213f15c52bcac9c1b58ccb.zip
Convert to new options framework
Diffstat (limited to 'deskutils/drivel')
-rw-r--r--deskutils/drivel/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/deskutils/drivel/Makefile b/deskutils/drivel/Makefile
index c3824db3d541..993718b6a364 100644
--- a/deskutils/drivel/Makefile
+++ b/deskutils/drivel/Makefile
@@ -16,7 +16,9 @@ COMMENT= Blog editor for GNOME
LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup
-OPTIONS= GTKSPELL "Enable GtkSpell support" On
+OPTIONS_DEFINE= GTKSPELL
+OPTIONS_DEFAULT= GTKSPELL
+GTKSPELL_DESC= Enable GtkSpell support
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
@@ -35,12 +37,12 @@ GCONF_SCHEMAS= drivel.schemas
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GTKSPELL)
-CONFIGURE_ARGS+= --without-gtkspell
-.else
+.if ${PORT_OPTIONS:MGTKSPELL}
LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+.else
+CONFIGURE_ARGS+= --without-gtkspell
.endif
post-patch:
@@ -48,4 +50,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|make -C|$$(MAKE) -C|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/-ldl/s|^|#|g' ${WRKSRC}/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>