aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/easystroke/Makefile
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-05-27 00:18:04 +0800
committerwg <wg@FreeBSD.org>2013-05-27 00:18:04 +0800
commitee5f252eae0147866d6b2fa3e7d99aec36c53f0d (patch)
treec9c8dcf7529e20efcff29c4713ac447843890742 /deskutils/easystroke/Makefile
parentaef8139a7c6c51250ecd212d2d990f60d53e4093 (diff)
downloadfreebsd-ports-gnome-ee5f252eae0147866d6b2fa3e7d99aec36c53f0d.tar.gz
freebsd-ports-gnome-ee5f252eae0147866d6b2fa3e7d99aec36c53f0d.tar.zst
freebsd-ports-gnome-ee5f252eae0147866d6b2fa3e7d99aec36c53f0d.zip
- Update to 0.6.0 [1]
- Add LICENSE (ISCL) - Unmute install commands Changes: https://github.com/thjaeger/easystroke/blob/94a862e9/changelog PR: ports/178751 [1] Submitted by: Tobias Kortkamp <tobias.kortkamp@gmail.com> (maintainer) Approved by: culot (mentor)
Diffstat (limited to 'deskutils/easystroke/Makefile')
-rw-r--r--deskutils/easystroke/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
index 8145974e1717..9e600f6e0b76 100644
--- a/deskutils/easystroke/Makefile
+++ b/deskutils/easystroke/Makefile
@@ -1,17 +1,19 @@
-# Created by: Tobias Kortkamp <tobias.kortkamp@gmail.com>
+# Created by: Tobias Kortkamp <tobias.kortkamp@gmail.com>
# $FreeBSD$
PORTNAME= easystroke
-PORTVERSION= 0.5.6
+PORTVERSION= 0.6.0
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= tobias.kortkamp@gmail.com
COMMENT= Easystroke is a gesture-recognition application for X11
+LICENSE= ISCL
+
BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man \
${LOCALBASE}/include/xorg/xserver-properties.h:${PORTSDIR}/x11-servers/xorg-server
-LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+LIB_DEPENDS= gtkmm-3:${PORTSDIR}/x11-toolkits/gtkmm30 \
dbus-glib:${PORTSDIR}/devel/dbus-glib \
boost_serialization:${PORTSDIR}/devel/boost-libs
@@ -20,14 +22,13 @@ MAN1= easystroke.1
USE_GCC= any
USE_XORG= x11 xtst
USE_GMAKE= yes
+USES+= gettext
INSTALLS_ICONS= yes
OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
-USES+= gettext
-
.if ${PORT_OPTIONS:MNLS}
BUILD_DEPENDS+= intltool-merge:${PORTSDIR}/textproc/intltool
PLIST_SUB+= NLS=""
@@ -44,17 +45,17 @@ pre-build:
do-install:
@${MKDIR} ${PREFIX}/bin/
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
@${MKDIR} ${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications/
@${MKDIR} ${PREFIX}/share/pixmaps/
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
@${MKDIR} ${PREFIX}/man/man1/
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MNLS}
@${MKDIR} ${PREFIX}/share/locale/
- @(cd ${WRKSRC}/po/ && \
+ (cd ${WRKSRC}/po/ && \
${COPYTREE_SHARE} \* ${PREFIX}/share/locale/ "-name *.mo")
.endif