aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/etoile-trackerkit
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-19 22:03:58 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-19 22:03:58 +0800
commit10d664e84b0a031841d99c34152aaf08b67c3e21 (patch)
treebe4af25fe6898f4a275f5e93798c879b8d6558c0 /deskutils/etoile-trackerkit
parent7dd66a411f62a69f03ce234de04aa190920cbd60 (diff)
downloadfreebsd-ports-gnome-10d664e84b0a031841d99c34152aaf08b67c3e21.tar.gz
freebsd-ports-gnome-10d664e84b0a031841d99c34152aaf08b67c3e21.tar.zst
freebsd-ports-gnome-10d664e84b0a031841d99c34152aaf08b67c3e21.zip
Etoile intends to be an innovative GNUstep based user environnement built
from the ground up on highly modular and light components with project and document orientation in mind, in order to allow users to create their own workflow by reshaping or recombining provided Services (aka Applications), Components etc. Flexibility and modularity on both User Interface and code level should allow us to scale from PDA to computer environment. This package installs the trackerkit framework. WWW: http://www.etoile-project.org/
Diffstat (limited to 'deskutils/etoile-trackerkit')
-rw-r--r--deskutils/etoile-trackerkit/Makefile42
-rw-r--r--deskutils/etoile-trackerkit/distinfo3
-rw-r--r--deskutils/etoile-trackerkit/pkg-descr10
-rw-r--r--deskutils/etoile-trackerkit/pkg-plist9
4 files changed, 64 insertions, 0 deletions
diff --git a/deskutils/etoile-trackerkit/Makefile b/deskutils/etoile-trackerkit/Makefile
new file mode 100644
index 000000000000..679bb7abfab3
--- /dev/null
+++ b/deskutils/etoile-trackerkit/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: etoile-trackerkit
+# Date created: 18 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= trackerkit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= http://florida.ethz.ch/ports/distfiles/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project frameowrks and bundles
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+LDCONFIG_DIRS= ${LOCALLIBDIR}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/TrackerKit
+
+HEADERS= TKCollection.h TKKeyValuePredicate.h TKObject.h \
+ TKQuery.h TKTracker.h
+
+post-install:
+ ${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Headers/TrackerKit
+.for i in ${HEADERS}
+ ${INSTALL_DATA} ${WRKSRC}/Frameworks/TrackerKit/Headers/${i} \
+ ${GNUSTEP_PREFIX}/System/Library/Headers/TrackerKit/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-trackerkit/distinfo b/deskutils/etoile-trackerkit/distinfo
new file mode 100644
index 000000000000..2d5c7ccf5d13
--- /dev/null
+++ b/deskutils/etoile-trackerkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile_0+20060917+dfsg.orig.tar.gz) = bc96dcaba7ac66abb1320d5cfc98f05e
+SHA256 (etoile_0+20060917+dfsg.orig.tar.gz) = de7cb026ccebdbb72d115ca800a13910cd51c9df27f5578ad7059b13f88eb334
+SIZE (etoile_0+20060917+dfsg.orig.tar.gz) = 10478850
diff --git a/deskutils/etoile-trackerkit/pkg-descr b/deskutils/etoile-trackerkit/pkg-descr
new file mode 100644
index 000000000000..5665ea299ded
--- /dev/null
+++ b/deskutils/etoile-trackerkit/pkg-descr
@@ -0,0 +1,10 @@
+Etoile intends to be an innovative GNUstep based user environnement built
+from the ground up on highly modular and light components with project and
+document orientation in mind, in order to allow users to create their own
+workflow by reshaping or recombining provided Services (aka Applications),
+Components etc. Flexibility and modularity on both User Interface and code
+level should allow us to scale from PDA to computer environment.
+
+This package installs the trackerkit framework.
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-trackerkit/pkg-plist b/deskutils/etoile-trackerkit/pkg-plist
new file mode 100644
index 000000000000..5ac4c2ae14f3
--- /dev/null
+++ b/deskutils/etoile-trackerkit/pkg-plist
@@ -0,0 +1,9 @@
+System/Library/Headers/TrackerKit/TKCollection.h
+System/Library/Headers/TrackerKit/TKKeyValuePredicate.h
+System/Library/Headers/TrackerKit/TKObject.h
+System/Library/Headers/TrackerKit/TKQuery.h
+System/Library/Headers/TrackerKit/TKTracker.h
+System/Library/Libraries/libTrackerKit.so
+System/Library/Libraries/libTrackerKit.so.%%MAJORLIBVERSION%%
+System/Library/Libraries/libTrackerKit.so.%%MAJORLIBVERSION%%.1
+@dirrm System/Library/Headers/TrackerKit