aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/evolution-jescs/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /deskutils/evolution-jescs/Makefile
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'deskutils/evolution-jescs/Makefile')
-rw-r--r--deskutils/evolution-jescs/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/deskutils/evolution-jescs/Makefile b/deskutils/evolution-jescs/Makefile
index 44971b2eadb1..711b2a9a0a18 100644
--- a/deskutils/evolution-jescs/Makefile
+++ b/deskutils/evolution-jescs/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/deskutils/evolution-jescs/Makefile,v 1.1 2005/09/08 14:22:13 marcus Exp $
+# $MCom: ports/deskutils/evolution-jescs/Makefile,v 1.9 2006/04/13 07:52:31 bland Exp $
#
PORTNAME= jescs
-PORTVERSION= 2.4.3
-PORTREVISION= 1
+PORTVERSION= 2.5.3
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PKGNAMEPREFIX}${PORTNAME}/2.4
+MASTER_SITE_SUBDIR= sources/${PKGNAMEPREFIX}${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMEPREFIX= evolution-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
@@ -24,14 +23,15 @@ RUN_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GETTEXT= yes
USE_PERL= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-EVO_VERSION= 2.4
-PLIST_SUB= EVO_VERSION=${EVO_VERSION} EDS_VERSION="1.2" VERSION="2.4"
+EVO_VERSION= 2.6
+PLIST_SUB= EVO_VERSION=${EVO_VERSION} EDS_VERSION="1.2" VERSION="2.6"
post-patch:
@${REINPLACE_CMD} -e 's|libdir/bonobo/servers|prefix/libdata/bonobo/servers|g' \