aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gcal
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-12-29 05:33:14 +0800
committerjohans <johans@FreeBSD.org>2013-12-29 05:33:14 +0800
commit8b33f445de730b72c54d6c2101b6d2d190fe1e44 (patch)
treed0c42ef3e82b71d1676eb333e8c5173851405c1e /deskutils/gcal
parent6e33e533e6b592bad2fcade1135febd805dce5e6 (diff)
downloadfreebsd-ports-gnome-8b33f445de730b72c54d6c2101b6d2d190fe1e44.tar.gz
freebsd-ports-gnome-8b33f445de730b72c54d6c2101b6d2d190fe1e44.tar.zst
freebsd-ports-gnome-8b33f445de730b72c54d6c2101b6d2d190fe1e44.zip
- Enable stage support
- Fix perl shebang path - Bump PORTREVISION
Diffstat (limited to 'deskutils/gcal')
-rw-r--r--deskutils/gcal/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/deskutils/gcal/Makefile b/deskutils/gcal/Makefile
index 52b0670f8bf3..1beaf15ce37d 100644
--- a/deskutils/gcal/Makefile
+++ b/deskutils/gcal/Makefile
@@ -1,10 +1,11 @@
# Created by: Cyrille Lefevre <clefevre@citeweb.net>
# $FreeBSD$
-PORTNAME= gcal
-PORTVERSION= 3.6.3
-CATEGORIES= deskutils
-MASTER_SITES= GNU
+PORTNAME= gcal
+PORTVERSION= 3.6.3
+PORTREVISION= 1
+CATEGORIES= deskutils
+MASTER_SITES= GNU
MAINTAINER= johans@FreeBSD.org
COMMENT= The GNU Gregorian calendar program
@@ -12,15 +13,15 @@ COMMENT= The GNU Gregorian calendar program
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
+USES= shebangfix
+SHEBANG_FILES= misc/gcalltx/gcalltxp.in misc/gcalltx/gcalltx.pl
INFO= gcal
-#MAN1= gcal.1 gcal2txt.1 tcal.1 txt2gcal.1
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USES= gettext
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
@@ -39,10 +40,11 @@ post-patch:
post-install:
@${TAR} -cf - -C ${WRKSRC} --exclude '*.in' --exclude '*.in.bak' \
- --exclude '*.alias' misc | ${TAR} -xpf - -C ${DATADIR}
+ --exclude '*.alias' misc | \
+ ${TAR} -xpf - -C ${STAGEDIR}${DATADIR}
.for p in ${GCAL_SCRIPTS}
- @${CHMOD} +x ${DATADIR}/misc/${p}
- @${LN} -s ${DATADIR}/misc/${p} ${PREFIX}/bin/gcal-${p:T}
+ @${CHMOD} +x ${STAGEDIR}${DATADIR}/misc/${p}
+ @${LN} -s ${DATADIR}/misc/${p} ${STAGEDIR}${PREFIX}/bin/gcal-${p:T}
.endfor
.include <bsd.port.mk>