aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gdesklets
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
committermarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
commit43bd9f14d9ce11690e9538bf3b03d3462faa6dbe (patch)
treeda347910089a96d6d726b8bb080f62c773263828 /deskutils/gdesklets
parent2e669ed08a56339ee1a8b2a0573a30147f95bd82 (diff)
downloadfreebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.gz
freebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.zst
freebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.zip
Presenting GNOME 2.20.1 and all related works for FreeBSD. The official
GNOME 2.20 release notes can be found at http://www.gnome.org/start/2.20/notes/en/ . Beyond that, this update includes the new GIMP 2.4 (courtesy of ahze). The GNOME 2.20 update also includes a huge change in the FreeBSD GNOME hierarchy. We are now using the more standard DATADIR of ${PREFIX}/share rather than ${PREFIX}/share/gnome. The result is that fewer patches and hacks are needed to port GNOME components to FreeBSD. This will mean some user changes may be required, so be sure to read /usr/ports/UPDATING for more details. This release and the things we accomplished in it would not have been possible without mezz's crazy idea to collapse DATADIR, and his persistence to make it happen successfully. Ahze and pav also deserve thanks for their work on porting modules and testing the whole ball of wax on pointyhat (respectively). The FreeBSD GNOME team would also like to thank our various testers and contributors: Yasuda Keisuke Frank Jahnke Pawel Worach Brian Gruber Franz Klammer Yuri Pankov Nick Barkas Cristian KLEIN Tony Maher Scot Hetzel Martin Matuska (mm) Benoit Dejean Martin Wilke (miwi) (And anyone else I may have missed) PRs fixed in this release: 111272, 113470, 115995, 116338
Diffstat (limited to 'deskutils/gdesklets')
-rw-r--r--deskutils/gdesklets/Makefile6
-rw-r--r--deskutils/gdesklets/files/patch-data::Makefile.in11
-rw-r--r--deskutils/gdesklets/files/patch-main::__init__.py11
-rw-r--r--deskutils/gdesklets/pkg-install2
-rw-r--r--deskutils/gdesklets/pkg-plist19
5 files changed, 14 insertions, 35 deletions
diff --git a/deskutils/gdesklets/Makefile b/deskutils/gdesklets/Makefile
index f15efdcdbc5f..7b2b3323e45d 100644
--- a/deskutils/gdesklets/Makefile
+++ b/deskutils/gdesklets/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdesklets
PORTVERSION= 0.35.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils gnome
MASTER_SITES= http://www.gdesklets.org/downloads/ \
http://www.pycage.de/download/${PORTNAME}/ \
@@ -45,8 +45,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_C
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
post-install:
- @${MKDIR} ${PREFIX}/share/gnome/gdesklets/Displays
- @${MKDIR} ${PREFIX}/share/gnome/gdesklets/Sensors
+ @${MKDIR} ${PREFIX}/share/gdesklets/Displays
+ @${MKDIR} ${PREFIX}/share/gdesklets/Sensors
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/lib/gdesklets
@${CAT} ${PKGMESSAGE}
diff --git a/deskutils/gdesklets/files/patch-data::Makefile.in b/deskutils/gdesklets/files/patch-data::Makefile.in
deleted file mode 100644
index 467ca7297f20..000000000000
--- a/deskutils/gdesklets/files/patch-data::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- data/Makefile.in.orig Tue Nov 14 13:33:28 2006
-+++ data/Makefile.in Tue Nov 14 13:36:09 2006
-@@ -252,7 +252,7 @@
- sharedmimepackagedir = $(sharedmimedir)/packages
- sharedmimepackage_in_files = gdesklets.xml.in
- sharedmimepackage_DATA = $(sharedmimepackage_in_files:.xml.in=.xml)
--mimeicondir = $(datadir)/icons/gnome/48x48/mimetypes
-+mimeicondir = $(prefix)/share/icons/gnome/48x48/mimetypes
- mimeicon_DATA = gnome-mime-application-x-gdesklets-display.png
- pixmapdir = $(PIXMAPDIR)
- pixmap_DATA = gdesklets.png
diff --git a/deskutils/gdesklets/files/patch-main::__init__.py b/deskutils/gdesklets/files/patch-main::__init__.py
deleted file mode 100644
index f9f873aa9852..000000000000
--- a/deskutils/gdesklets/files/patch-main::__init__.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/__init__.py.orig Thu Oct 5 16:14:40 2006
-+++ main/__init__.py Tue Nov 14 13:38:57 2006
-@@ -7,7 +7,7 @@
- # gDesklets home paths
- HOME = os.path.abspath(os.path.join(os.path.dirname(__file__), os.pardir))
- USERHOME = os.path.join(os.path.expanduser("~"), ".gdesklets")
--OLDHOME = os.path.join(HOME, os.pardir, os.pardir, "share", "gdesklets")
-+OLDHOME = os.path.join(HOME, os.pardir, os.pardir, "share", "gnome", "gdesklets")
-
- # we need the DISPLAY variable
- try:
diff --git a/deskutils/gdesklets/pkg-install b/deskutils/gdesklets/pkg-install
index 366e159fd31e..8a8d0cb4a84f 100644
--- a/deskutils/gdesklets/pkg-install
+++ b/deskutils/gdesklets/pkg-install
@@ -1,5 +1,5 @@
#!/bin/sh
if [ "$2" = "POST-INSTALL" ]; then
- mkdir -p ${PKG_PREFIX}/share/gnome/gdesklets/Displays
+ mkdir -p ${PKG_PREFIX}/share/gdesklets/Displays
fi
diff --git a/deskutils/gdesklets/pkg-plist b/deskutils/gdesklets/pkg-plist
index 7abc70cff434..d77246dc62c9 100644
--- a/deskutils/gdesklets/pkg-plist
+++ b/deskutils/gdesklets/pkg-plist
@@ -553,10 +553,10 @@ lib/gdesklets/utils/x11.so
lib/gdesklets/utils/xdr.py
lib/gdesklets/utils/xdr.pyc
lib/gdesklets/utils/xdr.pyo
-share/gnome/applications/gdesklets.desktop
-share/gnome/pixmaps/gdesklets.png
-@exec mkdir -p %D/share/gnome/gdesklets/Displays
-@exec mkdir -p %D/share/gnome/gdesklets/Sensors
+share/applications/gdesklets.desktop
+share/pixmaps/gdesklets.png
+@exec mkdir -p %D/share/gdesklets/Displays
+@exec mkdir -p %D/share/gdesklets/Sensors
share/icons/gnome/48x48/mimetypes/gnome-mime-application-x-gdesklets-display.png
share/locale/ar/LC_MESSAGES/gdesklets.mo
share/locale/az/LC_MESSAGES/gdesklets.mo
@@ -603,9 +603,9 @@ share/locale/gl/LC_MESSAGES/gdesklets.mo
share/locale/zh_HK/LC_MESSAGES/gdesklets.mo
share/mime/application/x-gdesklets-display.xml
share/mime/packages/gdesklets.xml
-@dirrm share/gnome/gdesklets/Sensors
-@dirrm share/gnome/gdesklets/Displays
-@dirrm share/gnome/gdesklets
+@dirrm share/gdesklets/Sensors
+@dirrm share/gdesklets/Displays
+@dirrm share/gdesklets
@dirrm lib/gdesklets/utils
@dirrm lib/gdesklets/shell/plugins/gDeskletsClient
@dirrm lib/gdesklets/shell/plugins/ViewSwitch
@@ -654,8 +654,9 @@ share/mime/packages/gdesklets.xml
@dirrm lib/gdesklets
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
@dirrmtry share/icons/gnome/48x48/mimetypes
+@dirrmtry share/applications