aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gnochm
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-12-02 15:32:34 +0800
committerpav <pav@FreeBSD.org>2004-12-02 15:32:34 +0800
commit5c75dbae1dfd9f43eb5c99e99b0661ecfb74add5 (patch)
tree900348a10c6e90d97f59447135ab7c7096f5a371 /deskutils/gnochm
parent29515446e9e783e2c662ecdd8a16db06502a36db (diff)
downloadfreebsd-ports-gnome-5c75dbae1dfd9f43eb5c99e99b0661ecfb74add5.tar.gz
freebsd-ports-gnome-5c75dbae1dfd9f43eb5c99e99b0661ecfb74add5.tar.zst
freebsd-ports-gnome-5c75dbae1dfd9f43eb5c99e99b0661ecfb74add5.zip
Add gnochm, a CHM file viewer. It is designed to integrate nicely with Gnome. It
uses PyCHM, a Python package that exports the CHMLIB API. Features are: * Full-text search support * Bookmarks * Gnome integration (on-line help, file associations, drag'n'drop from file manager, gnome menu entry) * Internationalisation support * Configurable support for HTTP links * Configurable support for external ms-its links WWW: http://gnochm.sourceforge.net/ PR: ports/74459 Submitted by: Radek Kozlowski <radek@raadradd.com>
Diffstat (limited to 'deskutils/gnochm')
-rw-r--r--deskutils/gnochm/Makefile38
-rw-r--r--deskutils/gnochm/distinfo2
-rw-r--r--deskutils/gnochm/files/patch-data-Makefile.in20
-rw-r--r--deskutils/gnochm/pkg-descr12
-rw-r--r--deskutils/gnochm/pkg-plist27
5 files changed, 99 insertions, 0 deletions
diff --git a/deskutils/gnochm/Makefile b/deskutils/gnochm/Makefile
new file mode 100644
index 000000000000..ff92bbeff308
--- /dev/null
+++ b/deskutils/gnochm/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gnochm
+# Date created: 25 November 2004
+# Whom: Radek Kozlowski <radek@raadradd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnochm
+PORTVERSION= 0.9.3
+CATEGORIES= deskutils python gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= radek@raadradd.com
+COMMENT= A GNOME viewer for CHM files
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/chm/_chmlib.so:${PORTSDIR}/textproc/pychm
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/chm/_chmlib.so:${PORTSDIR}/textproc/pychm
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack pygnome2
+USE_LIBTOOL_VER=15
+USE_PYTHON= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= gnochm.schemas
+INSTALLS_OMF= yes
+
+MAN1= gnochm.1
+MANCOMPRESSED= no
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@APPDATADIR@|@APPDATADIR@/gnome|' ${WRKSRC}/gnochm.py.in
+
+.include <bsd.port.mk>
diff --git a/deskutils/gnochm/distinfo b/deskutils/gnochm/distinfo
new file mode 100644
index 000000000000..636f25e90e08
--- /dev/null
+++ b/deskutils/gnochm/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnochm-0.9.3.tar.gz) = 8b5b8c16337e93366dda6667c11821b2
+SIZE (gnochm-0.9.3.tar.gz) = 276179
diff --git a/deskutils/gnochm/files/patch-data-Makefile.in b/deskutils/gnochm/files/patch-data-Makefile.in
new file mode 100644
index 000000000000..8b2ae596d812
--- /dev/null
+++ b/deskutils/gnochm/files/patch-data-Makefile.in
@@ -0,0 +1,20 @@
+--- data/Makefile.in.orig Thu Dec 2 01:00:48 2004
++++ data/Makefile.in Thu Dec 2 01:02:50 2004
+@@ -199,7 +199,7 @@
+ mime_DATA = gnochm.mime
+
+ # Should I use XDG_DATA_DIRS/mime/packages ????
+-sharedmimedir = $(datadir)/mime/packages
++sharedmimedir = $(prefix)/share/mime/packages
+ sharedmime_in_files = gnochm.xml.in
+ sharedmime_DATA = $(sharedmime_in_files:.xml.in=.xml)
+ man_MANS = gnochm.1
+@@ -543,7 +543,7 @@
+
+ install-data-hook:
+ if test "$(SHAREDMIME_TOOL)" != "no"; then \
+- $(SHAREDMIME_TOOL) $(datadir)/mime; \
++ $(SHAREDMIME_TOOL) $(prefix)/share/mime; \
+ fi
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/deskutils/gnochm/pkg-descr b/deskutils/gnochm/pkg-descr
new file mode 100644
index 000000000000..6dadc2bcc863
--- /dev/null
+++ b/deskutils/gnochm/pkg-descr
@@ -0,0 +1,12 @@
+GnoCHM is a CHM file viewer. It is designed to integrate nicely with Gnome. It
+uses PyCHM, a Python package that exports the CHMLIB API. Features are:
+
+ * Full-text search support
+ * Bookmarks
+ * Gnome integration (on-line help, file associations, drag'n'drop from file
+ manager, gnome menu entry)
+ * Internationalisation support
+ * Configurable support for HTTP links
+ * Configurable support for external ms-its links
+
+WWW: http://gnochm.sourceforge.net/
diff --git a/deskutils/gnochm/pkg-plist b/deskutils/gnochm/pkg-plist
new file mode 100644
index 000000000000..5e55be62f8d7
--- /dev/null
+++ b/deskutils/gnochm/pkg-plist
@@ -0,0 +1,27 @@
+bin/gnochm
+share/gnome/application-registry/gnochm.applications
+share/gnome/applications/gnochm.desktop
+share/gnome/gnochm/glade/gnochm.glade
+share/gnome/gnochm/glade/prefdialog.glade
+share/gnome/help/gnochm/C/gnochm.xml
+share/gnome/help/gnochm/C/legal.xml
+share/gnome/mime-info/gnochm.keys
+share/gnome/mime-info/gnochm.mime
+share/gnome/omf/gnochm/gnochm-C.omf
+share/gnome/pixmaps/chmfile.png
+share/gnome/pixmaps/gnochm.png
+share/gnome/pixmaps/gnochm_logo.png
+share/locale/de_DE/LC_MESSAGES/gnochm.mo
+share/locale/it/LC_MESSAGES/gnochm.mo
+share/locale/pt_BR/LC_MESSAGES/gnochm.mo
+share/locale/tr_TR/LC_MESSAGES/gnochm.mo
+share/locale/zh_CN/LC_MESSAGES/gnochm.mo
+share/mime/application/x-chm.xml
+share/mime/packages/gnochm.xml
+@dirrm share/gnome/omf/gnochm
+@dirrm share/gnome/help/gnochm/C
+@dirrm share/gnome/help/gnochm
+@dirrm share/gnome/gnochm/glade
+@dirrm share/gnome/gnochm
+@exec update-mime-database %D/share/mime
+@unexec update-mime-database %D/share/mime