aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gnomepim/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-06-03 02:15:00 +0800
committerade <ade@FreeBSD.org>2000-06-03 02:15:00 +0800
commit8fcd77c5cb25bda8aab456706e336553f982771d (patch)
tree3b01c0b7e25f7cf43ec46f464e921a5b85d6e714 /deskutils/gnomepim/Makefile
parent07e961994566d05c835b3a54c7c8dac0b8bb4156 (diff)
downloadfreebsd-ports-gnome-8fcd77c5cb25bda8aab456706e336553f982771d.tar.gz
freebsd-ports-gnome-8fcd77c5cb25bda8aab456706e336553f982771d.tar.zst
freebsd-ports-gnome-8fcd77c5cb25bda8aab456706e336553f982771d.zip
Add optional gnomepilot support (WITH_GNOMEPILOT directive)
The default is OFF, even if you have gnomepilot installed already. Problem reported by: Heath Nielson <heath@cs.byu.edu>
Diffstat (limited to 'deskutils/gnomepim/Makefile')
-rw-r--r--deskutils/gnomepim/Makefile27
1 files changed, 23 insertions, 4 deletions
diff --git a/deskutils/gnomepim/Makefile b/deskutils/gnomepim/Makefile
index abd97571117e..97587191e04a 100644
--- a/deskutils/gnomepim/Makefile
+++ b/deskutils/gnomepim/Makefile
@@ -16,15 +16,34 @@ MAINTAINER= ade@FreeBSD.org
LIB_DEPENDS= panel_applet.4:${PORTSDIR}/x11/gnomecore
+.if defined(WITH_GNOMEPILOT)
+LIB_DEPENDS+= gpilotd.0:${PORTSDIR}/palm/gnomepilot
+PILOTINC= "-I${LOCALBASE}/pilot/include"
+PILOTLIB= "-L${LOCALBASE}/pilot/lib"
+.else
+PILOTARGS= --without-pisock --disable-pilotlinktest
+EXTRA_PATCHES= ${FILESDIR}/patch.nopilot
+.endif
+
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ --datadir=${PREFIX}/share/gnome ${PILOTARGS}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PILOTINC}" \
GTK_CONFIG="${GTK_CONFIG}" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib ${PILOTLIB}"
+
+.if !defined(WITH_GNOMEPILOT)
+pre-extract:
+ @${ECHO} "You can add gnomepilot support by defining WITH_GNOMEPILOT"
+.endif
+
+.if defined(WITH_GNOMEPILOT)
+post-install:
+ @${CAT} ${PKGDIR}/PLIST.pilot >> ${TMPPLIST}
+.endif
.include <bsd.port.mk>