aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gnotime/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-03-01 15:24:45 +0800
committermarcus <marcus@FreeBSD.org>2003-03-01 15:24:45 +0800
commit9101a4537b833e2683bc5dae22734da5f9181220 (patch)
tree3e143a8a07e19bfb0f2a7f24aa7130138eab2f39 /deskutils/gnotime/Makefile
parenta6de9c0b318dd353109c35c6af0f65a6ff3e43d8 (diff)
downloadfreebsd-ports-gnome-9101a4537b833e2683bc5dae22734da5f9181220.tar.gz
freebsd-ports-gnome-9101a4537b833e2683bc5dae22734da5f9181220.tar.zst
freebsd-ports-gnome-9101a4537b833e2683bc5dae22734da5f9181220.zip
Add gnotime, a time tracking application for the GNOME 2 desktop.
PR: 48801 Submitted by: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
Diffstat (limited to 'deskutils/gnotime/Makefile')
-rw-r--r--deskutils/gnotime/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/deskutils/gnotime/Makefile b/deskutils/gnotime/Makefile
new file mode 100644
index 000000000000..24fbf1af100b
--- /dev/null
+++ b/deskutils/gnotime/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnotime
+# Date created: 1 March 2003
+# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnotime
+PORTVERSION= 2.1.5
+CATEGORIES= deskutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gttr
+
+MAINTAINER= martin.klaffenboeck@gmx.at
+COMMENT= GnoTime is a time tracker for gnome2
+
+LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gtkhtml-2.0:${PORTSDIR}/www/libgtkhtml \
+ guile.10:${PORTSDIR}/lang/guile
+
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -lgnuregex -lcompat"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+MAN1= gnotime.1
+
+.include <bsd.port.mk>