aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/google-gadgets/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-21 04:04:09 +0800
committermiwi <miwi@FreeBSD.org>2008-07-21 04:04:09 +0800
commitab57b99b08dbd99ab371e8f6d34747c8de099d4a (patch)
tree69f2ca97e77e7fbfe7302a9ca3d2e8797f79e20a /deskutils/google-gadgets/Makefile
parent95b91bfe4ce7ced25ff39020092b5098b7acc97f (diff)
downloadfreebsd-ports-gnome-ab57b99b08dbd99ab371e8f6d34747c8de099d4a.tar.gz
freebsd-ports-gnome-ab57b99b08dbd99ab371e8f6d34747c8de099d4a.tar.zst
freebsd-ports-gnome-ab57b99b08dbd99ab371e8f6d34747c8de099d4a.zip
- Update to 0.10.0
PR: 125801 Submitted by: Ashish Shukla <wahjava@gmail.com> (maintainer)
Diffstat (limited to 'deskutils/google-gadgets/Makefile')
-rw-r--r--deskutils/google-gadgets/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index 660fd8656ef8..ced2d7f5ef9c 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= google-gadgets
-PORTVERSION= 0.9.3
+PORTVERSION= 0.10.0
CATEGORIES= deskutils
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
@@ -27,15 +27,17 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
dbus-1.3:${PORTSDIR}/devel/dbus \
curl.4:${PORTSDIR}/ftp/curl \
rsvg-2.2:${PORTSDIR}/graphics/librsvg2
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefox
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefox \
+ ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gtk20
+USE_GCC= 4.2+
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" CPPFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-qt-host --enable-ltdl-install=no
+CONFIGURE_ARGS= --disable-qt-host --enable-ltdl-install=no --disable-update-mime-database
USE_AUTOTOOLS= libtool:15:env autoconf:261:env automake:110:env aclocal:110:env libltdl:15
OPTIONS= DEBUGGING "Enable debug output on runtime" on
@@ -52,4 +54,10 @@ post-patch:
pre-configure:
@cd ${WRKSRC} && ${SH} autotools/bootstrap.sh && ${CP} ${AUTOMAKE_DIR}/mkinstalldirs libltdl/
+post-deinstall:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
+
+post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.post.mk>