aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/google-gadgets/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-06-13 22:01:28 +0800
committerpav <pav@FreeBSD.org>2008-06-13 22:01:28 +0800
commitb0fb24467ea9e7a1b39d82cff35a40cecd5e49fd (patch)
tree9abf2976d1edfcf9e0d31530c208e890175a11df /deskutils/google-gadgets/Makefile
parentfcda2a43fc0ecdbd23f5905b61f8ad870fe4d4d7 (diff)
downloadfreebsd-ports-gnome-b0fb24467ea9e7a1b39d82cff35a40cecd5e49fd.tar.gz
freebsd-ports-gnome-b0fb24467ea9e7a1b39d82cff35a40cecd5e49fd.tar.zst
freebsd-ports-gnome-b0fb24467ea9e7a1b39d82cff35a40cecd5e49fd.zip
- Fix build on 6.x and minor changes
Submitted by: Ashish Shukla <wahjava@gmail.com> (maintainer)
Diffstat (limited to 'deskutils/google-gadgets/Makefile')
-rw-r--r--deskutils/google-gadgets/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index a914ee57d5c3..30daf23d4575 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus \
${LOCALBASE}/libdata/pkgconfig/libxml-2.0.pc:${PORTSDIR}/textproc/libxml2 \
${LOCALBASE}/libdata/pkgconfig/firefox-gtkmozembed.pc:${PORTSDIR}/www/firefox \
${LOCALBASE}/libdata/pkgconfig/cairo.pc:${PORTSDIR}/graphics/cairo \
- ${LOCALBASE}/libdata/pkgconfig/librsvg-2.0.pc:${PORTSDIR}/graphics/librsvg2
+ ${LOCALBASE}/libdata/pkgconfig/librsvg-2.0.pc:${PORTSDIR}/graphics/librsvg2 \
+ zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
xml2.5:${PORTSDIR}/textproc/libxml2 \
dbus-1.3:${PORTSDIR}/devel/dbus \
@@ -33,9 +34,13 @@ USE_GMAKE= yes
USE_GNOME= gnomehack gtk20
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" CPPFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-qt-host --enable-ltdl-install=no
-USE_AUTOTOOLS= libtool:15:env autoconf:261:env automake:110:env aclocal:110:env
+USE_AUTOTOOLS= libtool:15:env autoconf:261:env automake:110:env aclocal:110:env libltdl:15
+
+OPTIONS= DEBUGGING "Enable debug output on runtime" on
+
+.include <bsd.port.pre.mk>
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= --enable-debug
@@ -47,4 +52,4 @@ post-patch:
pre-configure:
@cd ${WRKSRC} && ${SH} autotools/bootstrap.sh && ${CP} ${AUTOMAKE_DIR}/mkinstalldirs libltdl/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>