aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gtg/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-17 05:11:39 +0800
committermiwi <miwi@FreeBSD.org>2009-03-17 05:11:39 +0800
commit8876a67fb51fd4f785dc1ed7b3c2164623c920f7 (patch)
tree01725b488df38c6d208390466dc4ab34fcc4fc58 /deskutils/gtg/Makefile
parent96b8b3d5a75027bd2414bba177acb000d93c9b2e (diff)
downloadfreebsd-ports-gnome-8876a67fb51fd4f785dc1ed7b3c2164623c920f7.tar.gz
freebsd-ports-gnome-8876a67fb51fd4f785dc1ed7b3c2164623c920f7.tar.zst
freebsd-ports-gnome-8876a67fb51fd4f785dc1ed7b3c2164623c920f7.zip
GTG is a personal organizer for the GNOME desktop environment,
it focuses on ease of use and flexibility, while keeping things simple. WWW: http://gtg.fritalk.com/ PR: ports/132676 Submitted by: Ruslan Mahmatkhanov <cvs-src at yandex.ru>
Diffstat (limited to 'deskutils/gtg/Makefile')
-rw-r--r--deskutils/gtg/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/deskutils/gtg/Makefile b/deskutils/gtg/Makefile
new file mode 100644
index 000000000000..79199b39c0d5
--- /dev/null
+++ b/deskutils/gtg/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gtg
+# Date created: 16 March 2009
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtg
+PORTVERSION= 0.1
+CATEGORIES= deskutils gnome python
+MASTER_SITES= http://launchpad.net/gtg/trunk/${PORTVERSION}/+download/
+
+MAINTAINER= cvs-src@yandex.ru
+COMMENT= GTD organizer for the GNOME desktop environment
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/configobj.py:${PORTSDIR}/devel/py-configobj \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/gobject/__init__.py:${PORTSDIR}/devel/py-gobject \
+ ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
+
+USE_GNOME= pygtk2
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+
+post-install:
+ @-update-desktop-database
+
+.include <bsd.port.mk>