aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/horde-mnemo/Makefile
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2006-04-16 00:11:25 +0800
committerscrappy <scrappy@FreeBSD.org>2006-04-16 00:11:25 +0800
commit926bb919a76a91145ce96aecb0f399e7679da855 (patch)
treeb7f3fd2b31130aac3a1f5daf3465c6f64e4467fd /deskutils/horde-mnemo/Makefile
parent0d8a16253dbc4d52c4478a0d64dcccf1bf083668 (diff)
downloadfreebsd-ports-gnome-926bb919a76a91145ce96aecb0f399e7679da855.tar.gz
freebsd-ports-gnome-926bb919a76a91145ce96aecb0f399e7679da855.tar.zst
freebsd-ports-gnome-926bb919a76a91145ce96aecb0f399e7679da855.zip
After a recent discussion on freebsd-ports, I have modified the Horde ports, so that
they now do not overwrite existing configuration files. Rather than backing up the old ones and allowing the user to merge the files by hand, config files are left untouched. Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'deskutils/horde-mnemo/Makefile')
-rw-r--r--deskutils/horde-mnemo/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/deskutils/horde-mnemo/Makefile b/deskutils/horde-mnemo/Makefile
index c768093122c6..c89b828222f1 100644
--- a/deskutils/horde-mnemo/Makefile
+++ b/deskutils/horde-mnemo/Makefile
@@ -30,7 +30,7 @@ USE_GETTEXT= yes
PLIST_SUB= MNEMODIR=${LMNEMODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= MNEMODIR=${MNEMODIR}
REINPLACE_ARGS= -i ""
@@ -66,11 +66,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${MNEMODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${MNEMODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${MNEMODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-mnemo.conf ${HORDE_INC}
@@ -83,6 +79,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}