aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/horde4-nag
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-01-06 08:38:13 +0800
committerthierry <thierry@FreeBSD.org>2006-01-06 08:38:13 +0800
commit922106489a63564790d516923e03c8fa28346fa9 (patch)
tree20dad146d367f92c711d016c12e8e3340824db6b /deskutils/horde4-nag
parent65a0f264588bfc3e5c26e6b14ba972c45fca49a3 (diff)
downloadfreebsd-ports-gnome-922106489a63564790d516923e03c8fa28346fa9.tar.gz
freebsd-ports-gnome-922106489a63564790d516923e03c8fa28346fa9.tar.zst
freebsd-ports-gnome-922106489a63564790d516923e03c8fa28346fa9.zip
- Replace WITH_APACHE2 by USE_APACHE, rename httpd.conf.xxx to
httpd-xxx.conf and fix configuration if APACHE_VERSION > 20. - Don't use the MCAL back-end by default for Kronolith, it is deprecated. - Deinstall bug reported by John Nielsen <john (at) jnielsen.net>: respect LHORDEDIR. - Fix horde-passwd installation / deinstallation. - Don't bump PORTREVISION, because running installations are not concerned.
Diffstat (limited to 'deskutils/horde4-nag')
-rw-r--r--deskutils/horde4-nag/Makefile19
-rw-r--r--deskutils/horde4-nag/files/pkg-deinstall.in (renamed from deskutils/horde4-nag/pkg-deinstall)2
-rw-r--r--deskutils/horde4-nag/pkg-plist2
3 files changed, 15 insertions, 8 deletions
diff --git a/deskutils/horde4-nag/Makefile b/deskutils/horde4-nag/Makefile
index 5928f9390e49..378160e55120 100644
--- a/deskutils/horde4-nag/Makefile
+++ b/deskutils/horde4-nag/Makefile
@@ -25,11 +25,12 @@ COMMENT= Nag is a simple, multiuser task list manager
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
NO_BUILD= yes
-USE_REINPLACE= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
-PLIST_SUB= NAGDIR=${LNAGDIR}
+PLIST_SUB= NAGDIR=${LNAGDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-deinstall
SUB_LIST= NAGDIR=${NAGDIR}
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -43,11 +44,17 @@ LNAGDIR?= ${LHORDEDIR}/nag
NAGDIR= ${PREFIX}/${LNAGDIR}
CONFDIR= ${NAGDIR}/config
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
+.else
HORDE_INC= ${LOCALBASE}/etc/horde
+.endif
pre-configure:
@${SED} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
- ${FILESDIR}/httpd.conf.nag > ${WRKDIR}/httpd.conf.nag
+ ${FILESDIR}/httpd.conf.nag > ${WRKDIR}/httpd-nag.conf
do-install:
@${MKDIR} ${NAGDIR}
@@ -62,7 +69,7 @@ do-install:
.endfor
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd.conf.nag ${HORDE_INC}
+ @${INSTALL_DATA} ${WRKDIR}/httpd-nag.conf ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -76,4 +83,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/horde4-nag/pkg-deinstall b/deskutils/horde4-nag/files/pkg-deinstall.in
index 266600fc1a29..8f85e546f5d4 100644
--- a/deskutils/horde4-nag/pkg-deinstall
+++ b/deskutils/horde4-nag/files/pkg-deinstall.in
@@ -9,7 +9,7 @@ if [ x$2 != xDEINSTALL ]; then
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls ${PKG_PREFIX}/www/horde/nag/config/*php`; do
+ for cf in `ls %%NAGDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
0) # original config file, will be deleted by pkg-plist
diff --git a/deskutils/horde4-nag/pkg-plist b/deskutils/horde4-nag/pkg-plist
index 14695a512690..f8516bc705b9 100644
--- a/deskutils/horde4-nag/pkg-plist
+++ b/deskutils/horde4-nag/pkg-plist
@@ -1,4 +1,4 @@
-etc/horde/httpd.conf.nag
+%%HORDE_INC%%/httpd-nag.conf
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/CREDITS