aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/kdepim3
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-03-10 03:41:12 +0800
committerlofi <lofi@FreeBSD.org>2004-03-10 03:41:12 +0800
commit344150edd9e7a3101f87e63d531bdae2b9dbb21f (patch)
treeaa2a54a33e5e6163905ac68a0a01153dd9038687 /deskutils/kdepim3
parent0bf4cb87335558d7d6c7a77212d01366ca69ca07 (diff)
downloadfreebsd-ports-gnome-344150edd9e7a3101f87e63d531bdae2b9dbb21f.tar.gz
freebsd-ports-gnome-344150edd9e7a3101f87e63d531bdae2b9dbb21f.tar.zst
freebsd-ports-gnome-344150edd9e7a3101f87e63d531bdae2b9dbb21f.zip
Update to KDE 3.2.1 / QT 3.3.1
Important changes: ================== KDE: - Audio/arts does not install artswrapper anymore, instead it is provided by audio/artswrapper. See UPDATING. - misc/kdeaddons3 is now a metaport with editors/kate-plugins editors/vimpart games/atlantikdesigner misc/kaddressbook-plugins misc/kfile-plugins misc/kicker-applets misc/knewsticker-scripts misc/konq-plugins misc/ksig misc/renamedlgplugins multimedia/noatun-plugins net/kontact-plugins as slave ports. - A number of KDE ports now uses OPTIONS do make various WITH_* options more visible. - Plist fixes - devel/kdevelop should be able to detect FreeBSD's autoconf/automake now for newly created projects. - kdebase will no longer remove previous KDM configurations. This won't take effect during the update from 3.2.0 to 3.2.1 (as deinstalling 3.2.0 will still remove the configuration), but subsequent updates will merge old configs. QT: - Previous versions of QT could be compiled with debugging-support enabled by defining DEBUG. This switch has been renamed to the more unambiguous WANT_QT_DEBUG (similar to WANT_KDE_DEBUG in the KDE ports).
Diffstat (limited to 'deskutils/kdepim3')
-rw-r--r--deskutils/kdepim3/Makefile44
-rw-r--r--deskutils/kdepim3/distinfo3
-rw-r--r--deskutils/kdepim3/files/patch-kmail-kmfilter.cpp44
-rw-r--r--deskutils/kdepim3/files/patch-kmail-kmfolderimap.cpp33
4 files changed, 37 insertions, 87 deletions
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 755b6d1ad517..5ad99ec867b3 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -7,16 +7,15 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
CATEGORIES= deskutils mail news kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Personal Information Management tools for KDE
-CONFLICTS= kdenetwork-3.1*
+CONFLICTS= kdenetwork-3.1.*
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
@@ -31,27 +30,54 @@ INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
KDE_BUILD_PLIST=yes
-.if exists(${LOCALBASE}/bin/pilot-link)
+OPTIONS= KPILOT "Build KPilot, hotsync software for KDE" off \
+ GNOKII "KAdressbook import/export for Nokia phones" off
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/pilot-xfer)
+. if !defined(WITH_KPILOT)
+KPILOT_OVERRIDE=yes
WITH_KPILOT= yes
+. endif
.endif
.if exists(${LOCALBASE}/bin/gnokii)
+. if !defined(WITH_GNOKII)
+GNOKII_OVERRIDE=yes
WITH_GNOKII= yes
+. endif
.endif
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
-
.if defined(WITH_GNOKII)
-LIB_DEPENDS+= gnokii.1:${PORTSDIR}/comms/gnokii
+LIB_DEPENDS+= gnokii:${PORTSDIR}/comms/gnokii
.endif # defined ($(WITH_GNOKII))
.if defined(WITH_KPILOT)
-LIB_DEPENDS= mal:${PORTSDIR}/palm/libmal \
+LIB_DEPENDS+= mal:${PORTSDIR}/palm/libmal \
pisock:${PORTSDIR}/palm/pilot-link
PLIST_APPEND+= plist.kpilot
.endif # defined ($(WITH_KPILOT))
+pre-everything::
+.if defined(KPILOT_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG} "* pilot-link is installed but WITH_KPILOT is not set! *"
+ @${ECHO_MSG} "* WITH_KPILOT has been enabled automatically. *"
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG}
+.endif
+.if defined(GNOKII_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG} "* gnokii is installed but WITH_GNOKII is not set! *"
+ @${ECHO_MSG} "* WITH_GNOKII has been enabled automatically. *"
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG}
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl|' ${WRKSRC}/configure
diff --git a/deskutils/kdepim3/distinfo b/deskutils/kdepim3/distinfo
index 3146352b8068..37c9dede25a2 100644
--- a/deskutils/kdepim3/distinfo
+++ b/deskutils/kdepim3/distinfo
@@ -1 +1,2 @@
-MD5 (KDE/kdepim-3.2.0.tar.bz2) = 657a61e0f3d90d2afec3820e77f81306
+MD5 (KDE/kdepim-3.2.1.tar.bz2) = 362bec23869328a85845e0501020c938
+SIZE (KDE/kdepim-3.2.1.tar.bz2) = 7754558
diff --git a/deskutils/kdepim3/files/patch-kmail-kmfilter.cpp b/deskutils/kdepim3/files/patch-kmail-kmfilter.cpp
deleted file mode 100644
index a2f23954cf93..000000000000
--- a/deskutils/kdepim3/files/patch-kmail-kmfilter.cpp
+++ /dev/null
@@ -1,44 +0,0 @@
---- kmail/kmfilter.cpp.orig Sun Nov 30 10:49:22 2003
-+++ kmail/kmfilter.cpp Thu Feb 5 13:33:53 2004
-@@ -147,9 +147,18 @@
- // that the pattern is purified.
- mPattern.readConfig(config);
-
-- if (bPopFilter)
-+ if (bPopFilter) {
- // get the action description...
-- mAction = (KMPopFilterAction) config->readNumEntry( "action" );
-+ QString action = config->readEntry( "action" );
-+ if ( action == "down" )
-+ mAction = Down;
-+ else if ( action == "later" )
-+ mAction = Later;
-+ else if ( action == "delete" )
-+ mAction = Delete;
-+ else
-+ mAction = NoAction;
-+ }
- else {
- QStringList sets = config->readListEntry("apply-on");
- if ( sets.isEmpty() && !config->hasKey("apply-on") ) {
-@@ -210,7 +219,19 @@
- mPattern.writeConfig(config);
-
- if (bPopFilter) {
-- config->writeEntry( "action", mAction );
-+ switch ( mAction ) {
-+ case Down:
-+ config->writeEntry( "action", "down" );
-+ break;
-+ case Later:
-+ config->writeEntry( "action", "later" );
-+ break;
-+ case Delete:
-+ config->writeEntry( "action", "delete" );
-+ break;
-+ default:
-+ config->writeEntry( "action", "" );
-+ }
- } else {
- QStringList sets;
- if ( bApplyOnInbound )
diff --git a/deskutils/kdepim3/files/patch-kmail-kmfolderimap.cpp b/deskutils/kdepim3/files/patch-kmail-kmfolderimap.cpp
deleted file mode 100644
index c27ffe4117aa..000000000000
--- a/deskutils/kdepim3/files/patch-kmail-kmfolderimap.cpp
+++ /dev/null
@@ -1,33 +0,0 @@
---- kmail/kmfolderimap.cpp.orig Sat Jan 17 13:55:08 2004
-+++ kmail/kmfolderimap.cpp Thu Feb 5 13:33:38 2004
-@@ -1207,7 +1207,16 @@
- {
- KURL url = mAccount->getUrl();
- KMFolderImap *msg_parent = static_cast<KMFolderImap*>(msg->parent());
-- url.setPath(msg_parent->imapPath() + ";UID=" + msg->headerField("X-UID"));
-+ QString uid = msg->headerField("X-UID");
-+ /* If the uid is empty the delete job below will nuke all mail in the
-+ folder, so we better safeguard against that. See ::expungeFolder, as
-+ to why. :( */
-+ if ( uid.isEmpty() ) {
-+ kdDebug( 5006 ) << "KMFolderImap::deleteMessage: Attempt to delete "
-+ "an empty UID. Aborting." << endl;
-+ return;
-+ }
-+ url.setPath(msg_parent->imapPath() + ";UID=" + uid );
- if ( mAccount->makeConnection() != ImapAccountBase::Connected )
- return;
- KIO::SimpleJob *job = KIO::file_delete(url, FALSE);
-@@ -1228,7 +1237,11 @@
- KMFolderImap *msg_parent = static_cast<KMFolderImap*>(msgList.first()->parent());
- for ( QStringList::Iterator it = sets.begin(); it != sets.end(); ++it )
- {
-- url.setPath(msg_parent->imapPath() + ";UID=" + *it);
-+ QString uid = *it;
-+ // Don't delete with no uid, that nukes the folder. Should not happen, but
-+ // better safe than sorry.
-+ if ( uid.isEmpty() ) continue;
-+ url.setPath(msg_parent->imapPath() + ";UID=" + uid);
- if ( mAccount->makeConnection() != ImapAccountBase::Connected )
- return;
- KIO::SimpleJob *job = KIO::file_delete(url, FALSE);
/td>. Sort PTHREAD_FILES.glewis2003-10-211-2/+3 * . Add a missing BUILD_DEPENDS on NSPR so the plugin builds.glewis2003-10-141-1/+2 * . Override PKGINSTALL to place it in WRKDIR, which is writeable, ratherglewis2003-10-131-0/+1 * . Update to 1.4.1p4.glewis2003-10-118-59/+613 * . Unset -Werror when compiling the NIO stuff. GCC 3.3.1 tends to generateglewis2003-10-111-0/+13 * . Sync with the change to linux-sun-jdk14 (it now installs inglewis2003-10-021-1/+1 * Update linux jdk location after recent linux-sun-jdk update to 1.4.2_01phantom2003-09-081-1/+1 * Warn users about requirement of having linprocfs mounted in order tophantom2003-08-041-2/+22 * Now expects bootstrap JDK in ${LOCALBASE}/linux-sun-jdk1.4.2.znerd2003-07-211-1/+3 * Unbreak package build after recent Greg's commit (which changedphantom2003-05-091-3/+3 * . Add $FreeBSD$glewis2003-05-021-0/+12 * Fix checking of libc_r capabilities at FreeBSD version whichphantom2003-03-151-6/+22 * Add runtime test to check of required libc_r functionality. I.e. warnphantom2003-03-142-8/+94 * Add notice about amount of disk space requiredphantom2003-03-131-0/+9 * Correct pkg-plistphantom2003-03-131-204/+0 * Make sure that demo/jfc/SwingSet2/resources does not exists (it should not,phantom2003-03-131-0/+2 * Fix build on 5.0-RELEASEphantom2003-03-131-0/+11 * Bump PORTREVISIONphantom2003-03-111-0/+1 * Since we have problems with running debuging binaries on some machinesphantom2003-03-111-0/+15 * Add patch which backouts some of my early compile hacks which now preventingphantom2003-03-111-0/+13 * I am pleased to announce first public -beta patchset of FreeBSD/Java portphantom2003-03-0710-2560/+2019 * Don't set IGNORE when PACKAGE_BUILDINGkris2003-03-041-2/+2 * de-pkg-commentglewis2003-03-012-1/+1 * 1. Bump PORTREVISION for this and previous changes.glewis2003-03-012-1/+91 * . Updated version of native threads for FreeBSD. This uses recentlyglewis2003-03-011-0/+726 * . Rename our internal gethostby{name,addr}_r functions to avoid collisions.glewis2003-03-011-0/+114 * . Respect LOCALBASE in the DEVTOOLS_PATH setting.glewis2003-03-011-0/+9 * . Add missing include of <sys/time.h>, needed by <sys/resource.h> forglewis2003-03-011-0/+12 * . Be consistent about our compiler settings. Using gcc32 here was bothglewis2003-03-011-0/+13 * . Resurrect patch accidentally removed in last commit.glewis2003-02-131-0/+18 * . Update to patchset 8.glewis2003-02-1312-1142/+2 * Be consistent. If we're going to explicitly use /sbin/sysctl to checkglewis2003-01-301-1/+1 * Use the full path to /sbin/sysctlkris2003-01-301-1/+1 * Don't remove system directories share/java, share/java/classes, andkris2002-11-111-3/+0 * . Add optional (default: off) runtime dependencies for the font packagesglewis2002-11-011-0/+10 * . Fix UDP packet broadcasting.glewis2002-11-012-1/+15 * . Check for open-motif with libXm.so, which we actually use, instead ofglewis2002-10-291-2/+2 * . In the informative message regarding downloading the necessary files,glewis2002-10-291-3/+3 * . echo -> ${ECHO_MSG}glewis2002-10-251-8/+8 * . Catch up with additional font.properties files.glewis2002-10-251-0/+3 * . Chinese font.properties and make glue.glewis2002-10-252-2/+245 * . More XIM fixes for Japanese users (and presumably others with similarglewis2002-10-192-0/+64 * . Link the Netscape 4 plugin against libintl to avoid a runtime linkglewis2002-10-191-0/+15 * . Russian and Ukrainian font property files and appropriate build changes.glewis2002-10-193-0/+416 * . Make the instructions for downloading the various source bits clearer.glewis2002-10-181-6/+26 * Not using IGNORE anymore to avoid package building.znerd2002-10-101-5/+2 * Unified one-line descriptions for JDK ports.znerd2002-08-121-1/+1 * Changed the installation directory of the Sun JDK 1.3.x for Linux toznerd2002-08-101-1/+1 * . Fix a typo in a message printed out to the user.glewis2002-08-091-1/+1 * Add a check in pre-build for a sysctl which will cause an error duringglewis2002-08-071-0/+9 * Improved font.properties.ja based on the Kochi fonts rather than theglewis2002-08-061-0/+308 * Now that sobomax has updated the system version of tar don't redefineglewis2002-08-061-2/+5 * Add in a patch from the porting repository that allows people to buildglewis2002-08-061-0/+62 * Update to patchset 7.glewis2002-07-2617-554/+2 * Remove unintentional dependency on readlink by replacing the call to itglewis2002-07-151-1/+1 * Only depend on the Linux JDK when NATIVE_BOOTSTRAP isn't defined.glewis2002-07-081-1/+3 * Add a pre-build target to check for a setting of WRKDIRPREFIX which willglewis2002-06-271-0/+13 * Add open-motif to RUN_DEPENDS temporarily until we teach the JDK toglewis2002-06-261-0/+1 * . Fix dependencies after recent JDK ports repo copy.glewis2002-06-141-16/+19 * . Fix compilation on FreeBSD 4.2 by including <sys/param.h>glewis2002-06-121-0/+20 * Rename monstrously long patch filenames that were causing tar to exceedkris2002-06-0612-11/+11 * Use correct Open Motif.obrien2002-05-281-2/+1 * Add a NATIVE_BOOTSTRAP knob which allows people to bootstrap withglewis2002-05-031-0/+4 * Really fix the incompatibilities with gettext 0.11. The previousglewis2002-05-039-10/+176 * Correct pkg-plist.sobomax2002-04-231-1/+1 * Fix the build of libaudio.so on 5-CURRENT by using <sys/soundcard.h>glewis2002-04-172-0/+32 * Add a temporary dependency on gettext-old and use msgfmt-old to processglewis2002-04-172-0/+10 * Bump PORTREVISION due to the last two changes to the port.glewis2002-04-161-1/+1 * Fix some crash bugs in the browser plugin code by usingglewis2002-04-161-0/+31 * Add Taiwan Chinese font properties support (if I understandglewis2002-04-163-0/+255 * Start my bid for world domination by taking maintainershipglewis2002-04-161-1/+1 * A better fix for creating src.jar. Using tar by itself fails because theglewis2002-04-121-5/+4 * Fix user and group ownership of the installed files when they have beenglewis2002-04-121-4/+4 * Now creating an 'ext' directory as a subdirectory ofznerd2002-04-072-1/+3 * Correct when WITHOUT_PLUGIN is defined.sobomax2002-03-151-5/+5 * Link Mozilla pligin with libXt to make it working with Mozilla-0.9.9. Thissobomax2002-03-133-4/+23 * Bumped PORTREVISION. Added a patch earlier today, and theznerd2002-03-121-0/+1 * Fixes the problem that the source JAR is too small.znerd2002-03-111-0/+26 * Add urwfonts into RUN_DEPENDS to prevent lot of "missed font" warnings whensobomax2002-03-061-1/+2 * Corrected the gtk version number at the request of Greg Lewis.davidc2002-02-201-1/+1 * Use correct LIB_DEPENDS.sobomax2002-02-201-1/+1 * Correct pkg-plist in the default and NODEBUG cases.sobomax2002-02-191-6/+6 * Fix ampersand entities...patrick2002-02-151-7/+7 * Update to patch set 6patrick2002-02-143-2/+207 * Use java@FreeBSD.org as a MAINTAINER, so question will go into appropriatesobomax2001-12-141-1/+1 * Update to patchlevel 5.sobomax2001-10-165-73/+7 * Fix a potential crash on 5-CURRENT.sobomax2001-09-122-0/+29 * Update to patchlevel 4. This release contains many critical bug fixes, sosobomax2001-09-106-300/+55 * Add native port of Sun's Java Devepment Kit, v.1.3.1 (repo-copied fromsobomax2001-08-28