aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/kdepim4/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-10-19 23:57:27 +0800
committermakc <makc@FreeBSD.org>2014-10-19 23:57:27 +0800
commit25c68bc4526056d98d62f1efe29e6059f175ce69 (patch)
tree7d99a8b7b1226b2da14c7c6d04800d30a417873e /deskutils/kdepim4/Makefile
parent2cd94a0cdc2c275bb71369d565efbaccb4a48c1b (diff)
downloadfreebsd-ports-gnome-25c68bc4526056d98d62f1efe29e6059f175ce69.tar.gz
freebsd-ports-gnome-25c68bc4526056d98d62f1efe29e6059f175ce69.tar.zst
freebsd-ports-gnome-25c68bc4526056d98d62f1efe29e6059f175ce69.zip
KDE/FreeBSD team presents KDE SC 4.14.2 and KDE Workspace 4.11.13!
USE_KDE4=kdehier component has been deprecated, new components added: baloo - Baloo core libraries baloo-widgets - Baloo widgets library kfilemetadata - KDE library for extracting file metadata New ports: graphics/kqtquickcharts - QtQuick plugin to render interactive charts misc/artikulate - Pronunciation trainer for KDE (not usable currently, links to both GStreamer 1.x and 0.10.x via dependencies) sysutils/baloo[-widgets] - KDE framework for searching and managing user metadata sysutils/kfilemetadata - Library for extracting file metadata l10n ports: - Farsi (Persian) and Indonesian translations has been readded - Vietnamese didn't pass threshold for inclusion into release astro/kstars: - switch dependency from math/eigen2 to math/eigen3 - add PYKDE option for updating supernovae data deskutils/kdepim4: - update dependencies: add libkgapi and baloo, remove now needless clucene, link-grammar, strigi - add patch to fix build with gcc42 - update COMMENT and description for all KDE PIM ports devel/ruby-krossruby: - remove BROKEN, it builds with ruby 2.x now editors/kate: - add patch to disable memory-hungry build of the kate tests [1] graphics/okular: - add dependency on graphics/libkscreen math/cantor: - add optional dependency on lang/luajit for LuaJIT backend - fix gfortran detection [2] misc/kdehier4: - adapt to new pkg world. Now the purpose of kdehier4 only to link some stuff between KDE4_PREFIX and LOCALBASE. science/kalzium: - switch dependency from math/eigen2 to math/eigen3 - add dependence on science/chemical-mime-data x11-themes/kdeartwork4 - switch dependency from math/eigen2 to math/eigen3 among other changes: - drop deprecated USE_KDE4=kdehier - drop @dirrm from plist - clean up pkg-descr - convert to options helpers - other portlint fixes The area51 repository features commits by alonso, rakuco and myself. PR: 187150 [1] Reported by: pe.freethread@live.com Patch by: Tobias Berner <tcberner@gmail.com> PR: 180674 [2] Reported by: torsten.eichstaedt@web.de PR: 194316 Exp-run: antoine
Diffstat (limited to 'deskutils/kdepim4/Makefile')
-rw-r--r--deskutils/kdepim4/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 48c8e7814eb5..d9e1b9b76ebf 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -3,33 +3,31 @@
PORTNAME= kdepim
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 3
CATEGORIES= deskutils kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
-COMMENT= Libraries for KDE-PIM applications
+COMMENT= KDE PIM applications
LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
libassuan.so:${PORTSDIR}/security/libassuan \
libsasl2.so:${PORTSDIR}/security/cyrus-sasl2 \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libgrantlee_gui.so:${PORTSDIR}/devel/grantlee \
- libclucene-core.so:${PORTSDIR}/textproc/clucene \
- liblink-grammar.so:${PORTSDIR}/textproc/link-grammar
+ libkgapi2.so:${PORTSDIR}/devel/libkgapi
RUN_DEPENDS= ${KDE4_PREFIX}/bin/accountwizard:${PORTSDIR}/deskutils/kdepim4-runtime \
${LOCALBASE}/bin/gmd5sum:${PORTSDIR}/sysutils/coreutils
CONFLICTS_INSTALL= kdepim44-4.*
USE_GNOME= libxml2 libxslt:build
-USE_KDE4= kdehier kdelibs kdeprefix pimlibs kactivities \
- akonadi automoc4 ontologies soprano strigi nepomuk-widgets
+USE_KDE4= kdelibs kdeprefix pimlibs kactivities \
+ akonadi automoc4 soprano nepomuk-widgets baloo
USES= cmake:outsource gmake iconv tar:xz
USE_OPENLDAP= yes
USE_QT4= corelib dbus declarative designer_build gui network opengl \
- script sql webkit \
+ qt3support script sql webkit xml \
qmake_build moc_build rcc_build uic_build
USE_XORG= x11 xscrnsaver
CMAKE_ARGS+= -DKDEPIM_BUILD_MOBILE:BOOL=FALSE
@@ -39,6 +37,11 @@ CXXFLAGS+= -Wno-error=return-type
USE_LDCONFIG= yes
MAKE_ENV= XDG_CONFIG_HOME=/dev/null
-PLIST_SUB= GRANTLEE_VER=0.4
+PLIST_SUB= GRANTLEE_VER=0.5
+
+post-patch:
+# Remove BOM
+ ${REINPLACE_CMD} -e '1 s|^.*/|/|g' \
+ ${WRKSRC}/knotes/configdialog/knotecollectionconfigwidget.cpp
.include <bsd.port.mk>