aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/kdepim44/Makefile
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-03-21 02:17:55 +0800
committerlofi <lofi@FreeBSD.org>2005-03-21 02:17:55 +0800
commit60b6a057a44d87d2f607ab5e5cc5d51ae882f026 (patch)
tree7b12a7f6a63013ec7c76a7ea1769e6f1b86deb38 /deskutils/kdepim44/Makefile
parentf4d228140101e5487a5373a70f4f0d13073ec43f (diff)
downloadfreebsd-ports-gnome-60b6a057a44d87d2f607ab5e5cc5d51ae882f026.tar.gz
freebsd-ports-gnome-60b6a057a44d87d2f607ab5e5cc5d51ae882f026.tar.zst
freebsd-ports-gnome-60b6a057a44d87d2f607ab5e5cc5d51ae882f026.zip
Update to KDE 3.4
Diffstat (limited to 'deskutils/kdepim44/Makefile')
-rw-r--r--deskutils/kdepim44/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/deskutils/kdepim44/Makefile b/deskutils/kdepim44/Makefile
index 4e952db77929..53cd62854309 100644
--- a/deskutils/kdepim44/Makefile
+++ b/deskutils/kdepim44/Makefile
@@ -7,7 +7,6 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
CATEGORIES= deskutils mail news palm kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -18,9 +17,10 @@ COMMENT= Personal Information Management tools for KDE
LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
mal:${PORTSDIR}/palm/libmal \
- pisock:${PORTSDIR}/palm/pilot-link
+ pisock:${PORTSDIR}/palm/pilot-link \
+ sasl2:${PORTSDIR}/security/cyrus-sasl2
-CONFLICTS= kdenetwork-3.1.* kdeaddons-kontact-plugins-[0-9]* kdepim-kpilot-3.2.3
+CONFLICTS= akregator-[0-9]* kdenetwork-3.1.* kdeaddons-kontact-plugins-[0-9]* kdepim-kpilot-3.2.3
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
@@ -41,6 +41,10 @@ OPTIONS= GNOKII "KAdressbook import/export for Nokia phones" off
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500035
+RUN_DEPENDS+= ${LOCALBASE}/lib/libssl.so:${PORTSDIR}/security/openssl
+.endif
+
.if exists(${LOCALBASE}/bin/gnokii)
. if !defined(WITH_GNOKII)
GNOKII_OVERRIDE=yes
@@ -66,12 +70,4 @@ pre-everything::
@${ECHO_MSG}
.endif
-.if ${OSVERSION} >= 501111 && !defined(NO_BLUETOOTH)
-_LBLUETOOTH= -lbluetooth
-.endif
-
-pre-configure:
- ${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl ${_LBLUETOOTH}|' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>