aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/kdepim44
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-01-05 10:29:15 +0800
committerwill <will@FreeBSD.org>2002-01-05 10:29:15 +0800
commit505481ccf3bef290cc1f4bc479f1301fcdf862b6 (patch)
tree91d4e03368661bbc9e9b31f090129fb7c61b5839 /deskutils/kdepim44
parent6197c75904d4e9a34849cea83c831f9290990e21 (diff)
downloadfreebsd-ports-gnome-505481ccf3bef290cc1f4bc479f1301fcdf862b6.tar.gz
freebsd-ports-gnome-505481ccf3bef290cc1f4bc479f1301fcdf862b6.tar.zst
freebsd-ports-gnome-505481ccf3bef290cc1f4bc479f1301fcdf862b6.zip
Conditionalize use of objprelink based on whether we're running on
MACHINE_ARCH=i386 *and* whether NO_KDE_OBJPRELINK is defined. Requested by: several
Diffstat (limited to 'deskutils/kdepim44')
-rw-r--r--deskutils/kdepim44/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/deskutils/kdepim44/Makefile b/deskutils/kdepim44/Makefile
index 226f3fbdb51a..df618f1d2dd2 100644
--- a/deskutils/kdepim44/Makefile
+++ b/deskutils/kdepim44/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_KDELIBS_VER=2
@@ -24,9 +26,11 @@ USE_BISON= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-objprelink \
- --with-extra-includes=${LOCALBASE}/pilot/include \
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/pilot/include \
--with-extra-libs=${LOCALBASE}/pilot/lib
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif