aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/kompose/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2004-09-02 06:04:50 +0800
committerwill <will@FreeBSD.org>2004-09-02 06:04:50 +0800
commit845fd81a3515d20967fe0ccc80b90f3927e6047c (patch)
treebde35fa44d60aa004317352ae197bf05ec16e4f0 /deskutils/kompose/Makefile
parent77df7ce717414b921ca9b8790b5b02e1f116b4fc (diff)
downloadfreebsd-ports-gnome-845fd81a3515d20967fe0ccc80b90f3927e6047c.tar.gz
freebsd-ports-gnome-845fd81a3515d20967fe0ccc80b90f3927e6047c.tar.zst
freebsd-ports-gnome-845fd81a3515d20967fe0ccc80b90f3927e6047c.zip
Add kompose 0.4.2, a full-screen task manager similar to Exposé(tm).
Submitted by: Lauri Watts <lauri@kde.org>
Diffstat (limited to 'deskutils/kompose/Makefile')
-rw-r--r--deskutils/kompose/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/kompose/Makefile b/deskutils/kompose/Makefile
new file mode 100644
index 000000000000..6dda58fe27af
--- /dev/null
+++ b/deskutils/kompose/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: kompose
+# Date created: 31 Aug 2004
+# Whom: Lauri Watts <lauri@kde.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kompose
+PORTVERSION= 0.4.2
+CATEGORIES= deskutils kde
+MASTER_SITES= http://download.berlios.de/kompose/
+
+MAINTAINER= lauri@kde.org
+COMMENT= Full-screen task manager similar to Exposé(tm)
+
+LIB_DEPENDS= Imlib2:${PORTSDIR}/graphics/imlib2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_KDELIBS_VER= 3
+GNU_CONFIGURE= yes
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2 ||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>