aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/launchy/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
committermakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
commita24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e (patch)
tree9d348bd41c93dc07e16d63761a277862fca2beec /deskutils/launchy/Makefile
parent59c0a46aa2540ee31e961d5f970ecb9f7804f01e (diff)
downloadfreebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.gz
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.zst
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.zip
- Convert unmaintained ports to USES=qmake
- Add stage support - Convert LIB_DEPENDS to new syntax - Minor changes/fixes
Diffstat (limited to 'deskutils/launchy/Makefile')
-rw-r--r--deskutils/launchy/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/deskutils/launchy/Makefile b/deskutils/launchy/Makefile
index 59337ad3cf12..64cfc7bfc6eb 100644
--- a/deskutils/launchy/Makefile
+++ b/deskutils/launchy/Makefile
@@ -13,12 +13,13 @@ COMMENT= Open source keystroke launcher
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/bin/xdg-open:${PORTSDIR}/devel/xdg-utils
+USES= qmake
USE_DOS2UNIX= readme.lyx readme.txt
USE_QT4= qmake_build moc_build rcc_build uic_build gui network
PORTDOCS= *
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
+
.include <bsd.port.options.mk>
post-patch:
@@ -31,14 +32,10 @@ post-patch:
${WRKSRC}/plugins/weby/weby.pro \
${WRKSRC}/src/src.pro
-do-configure:
- @(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} -r Launchy.pro)
-
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/?eadme.* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/?eadme.* ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>