aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/libopensync-plugin-python-devel/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-06-09 06:30:55 +0800
committermiwi <miwi@FreeBSD.org>2009-06-09 06:30:55 +0800
commitad6dcb178b410931b8a584938b44fc4da53756f8 (patch)
tree8ce0d77d48a49a1635170171ab0c9ebe5244ee5c /deskutils/libopensync-plugin-python-devel/Makefile
parente4a324dde12b05e8afc0511401cb97ac0ae57582 (diff)
downloadfreebsd-ports-gnome-ad6dcb178b410931b8a584938b44fc4da53756f8.tar.gz
freebsd-ports-gnome-ad6dcb178b410931b8a584938b44fc4da53756f8.tar.zst
freebsd-ports-gnome-ad6dcb178b410931b8a584938b44fc4da53756f8.zip
- Update lang/python26 and make Python 2.6.2 to the default Python version
Tested by: 3 pointyhat runs Thanks to: pav, gahr, lwhsu, mva, amdmi3
Diffstat (limited to 'deskutils/libopensync-plugin-python-devel/Makefile')
-rw-r--r--deskutils/libopensync-plugin-python-devel/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/deskutils/libopensync-plugin-python-devel/Makefile b/deskutils/libopensync-plugin-python-devel/Makefile
index 54a2817cd1de..9aa66f56ef27 100644
--- a/deskutils/libopensync-plugin-python-devel/Makefile
+++ b/deskutils/libopensync-plugin-python-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libopensync-plugin-python
PORTVERSION= 0.36
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
PKGNAMESUFFIX= -devel
@@ -21,10 +21,24 @@ CONFLICTS= libopensync-plugin-python-0.2*
USE_BZIP2= yes
USE_CMAKE= yes
-CMAKE_ARGS+= -Wno-dev
+USE_PYTHON= yes
+USE_GNOME= pkgconfig
+CMAKE_ARGS+= -Wno-dev \
+ -DPYTHON_INCLUDE_PATH:PATH=${PYTHON_INCLUDEDIR} \
+ -DPYTHON_LIBRARY:PATH=${PYTHON_LIBDIR}/config/lib${PYTHON_VERSION}.so
+
+# This hack is meant to respect PREFIX, and should be
+# enhanced to use pkg-config or cmake.
+OS_PLUGIN_DIR= ${PREFIX}/lib/opensync-1.0/plugins
+OS_PYPLUGIN_DIR=${PREFIX}/lib/opensync-1.0/python-plugins
pre-patch:
@${REINPLACE_CMD} -e "s|MESSAGE|# MESSAGE|" \
${WRKSRC}/cmake/modules/MacroEnsureOutOfSourceBuild.cmake
+do-install:
+ ${MKDIR} -p ${OS_PLUGIN_DIR} ${OS_PYPLUGIN_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/python-module.so ${OS_PLUGIN_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/sample.py ${OS_PYPLUGIN_DIR}
+
.include <bsd.port.mk>