aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/lightning-thunderbird/Makefile
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-08-17 02:36:10 +0800
committerflo <flo@FreeBSD.org>2011-08-17 02:36:10 +0800
commitf30e4f8c2ccfccd22500e1dab7986252daec9c75 (patch)
tree09bd069151a392d047530baff70488647f82fc18 /deskutils/lightning-thunderbird/Makefile
parentd0640767d953a29134f9019f7bec356f719ff180 (diff)
downloadfreebsd-ports-gnome-f30e4f8c2ccfccd22500e1dab7986252daec9c75.tar.gz
freebsd-ports-gnome-f30e4f8c2ccfccd22500e1dab7986252daec9c75.tar.zst
freebsd-ports-gnome-f30e4f8c2ccfccd22500e1dab7986252daec9c75.zip
retire GECKO_PTHREAD_LIBS just use PTHREAD_LIBS.
this will enable compilation with clang. firefox 6 and thunderbid 6 now build fine with clang. other gecko ports should become compilable as soon as they are based on the same gecko version as firefox and thunderbird 6
Diffstat (limited to 'deskutils/lightning-thunderbird/Makefile')
-rw-r--r--deskutils/lightning-thunderbird/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/deskutils/lightning-thunderbird/Makefile b/deskutils/lightning-thunderbird/Makefile
index 9a82418d78e1..d6c275e41786 100644
--- a/deskutils/lightning-thunderbird/Makefile
+++ b/deskutils/lightning-thunderbird/Makefile
@@ -61,8 +61,6 @@ EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
EXTRA_PATCHES= ${FILESDIR}/liboggplay_oss
.endif
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if defined(WITHOUT_DBUS)
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
@@ -71,7 +69,7 @@ LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${MOZSRC}/storage/build/Makefile.in \
${MOZSRC}/db/sqlite3/src/Makefile.in
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \