aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/logjam
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-21 00:04:23 +0800
committerkrion <krion@FreeBSD.org>2004-06-21 00:04:23 +0800
commitf91a9c153b8de235c56e32b88146adf0ee26e873 (patch)
treed82a3c1f7ab0c40e108ed00a3d28bb2acd2f1686 /deskutils/logjam
parentd1ed68beb5f0e9a97a8c34e25188d72442cef145 (diff)
downloadfreebsd-ports-gnome-f91a9c153b8de235c56e32b88146adf0ee26e873.tar.gz
freebsd-ports-gnome-f91a9c153b8de235c56e32b88146adf0ee26e873.tar.zst
freebsd-ports-gnome-f91a9c153b8de235c56e32b88146adf0ee26e873.zip
Fix a bug with syncing offline copy with LiveJournal.
PR: ports/68123 Submitted by: maintainer
Diffstat (limited to 'deskutils/logjam')
-rw-r--r--deskutils/logjam/Makefile2
-rw-r--r--deskutils/logjam/files/patch-src::sync.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index afdc9975a365..6d2af9a9719c 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= logjam
PORTVERSION= 4.4.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= deskutils
MASTER_SITES= http://logjam.danga.com/download/
diff --git a/deskutils/logjam/files/patch-src::sync.c b/deskutils/logjam/files/patch-src::sync.c
new file mode 100644
index 000000000000..5d010136d36a
--- /dev/null
+++ b/deskutils/logjam/files/patch-src::sync.c
@@ -0,0 +1,15 @@
+--- protocol/liblivejournal/livejournal/sync.c.old Fri Jun 18 14:57:51 2004
++++ protocol/liblivejournal/livejournal/sync.c Fri Jun 18 14:58:20 2004
+@@ -33,8 +33,10 @@
+ static int
+ entry_date_compare_func(const void *a, const void *b) {
+ /* struct tm* cast needed to un-constify the times passed to mktime. */
+- const LJEntry *entrya = a; time_t timea = mktime((struct tm*)&entrya->time);
+- const LJEntry *entryb = b; time_t timeb = mktime((struct tm*)&entryb->time);
++ const LJEntry *entrya = *(LJEntry **)a;
++ const LJEntry *entryb = *(LJEntry **)b;
++ time_t timea = mktime((struct tm*)&entrya->time);
++ time_t timeb = mktime((struct tm*)&entryb->time);
+ /* mktime actually converts the times to local time, which isn't
+ * quite correct, but since we're comparing times directly like this
+ * it should still sort the same way and timegm is potentially slower. */